Bluetooth Audio becomes stuttering while downloading or heavy use in network data via ethernet

I had this problem with Manjaro on my macbookpro 2016.

Now I am having same problem with Fedora 35 on PC. I googled it and some forums says it causes due to 2.4 GHz issues with Wifi.But now I am using ether-net cable and it is still happening.

It doesn’t matter what I’m playing it offline or online source. Audio becomes lag when I am downloading files.

I am using also using MX Master2s.

  • pipewire on both manjaro and fedora

  • Sony WH1000XM3 ( LDAC )

  • Orico Bluetooth 5.0 Adapter on PC

Welcome to ask.:fedora:edora @sherrinford

Could you please give us more info’s as :

inxi -Fzx in terminal and post the output as </> Preformatted text here.

Have also a look to pw-top to see what goes on when you open something with audio/video.

Just check, if you use USB3 to power your Bluetooth. If you need an extension cable for USB look for a good one and keep it short. Preferably use USB3 on backside …

Did you try without the mouse once, to see if the problem still exists.

inxi -Fzx

System:    Kernel: 5.15.8-200.fc35.x86_64 x86_64 bits: 64 compiler: gcc v: 2.37-10.fc35 Desktop: GNOME 41.2
           Distro: Fedora release 35 (Thirty Five)
Machine:   Type: Desktop Mobo: Gigabyte model: B550 GAMING X V2 serial: <superuser required> UEFI: American Megatrends LLC.
           v: F14e date: 10/13/2021
CPU:       Info: 6-Core model: AMD Ryzen 5 5600G with Radeon Graphics bits: 64 type: MT MCP arch: Zen 3 rev: 0 cache:
           L2: 3 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 93420
           Speed: 1896 MHz min/max: 1400/3900 MHz boost: enabled Core speeds (MHz): 1: 1896 2: 2135 3: 2330 4: 1781 5: 1631
           6: 1445 7: 1562 8: 1694 9: 2147 10: 2601 11: 2322 12: 1409
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Cezanne vendor: Gigabyte driver: amdgpu v: kernel bus-ID: 05:00.0
           Display: x11 server: X.Org 1.20.14 driver: loaded: amdgpu,ati unloaded: fbdev,modesetting,vesa
           resolution: 2560x1080
           OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.8-200.fc35.x86_64 LLVM 13.0.0) v: 4.6 Mesa 21.3.2
           direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Renoir Radeon High Definition Audio driver: snd_hda_intel v: kernel
           bus-ID: 05:00.1
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
           bus-ID: 05:00.6
           Sound Server-1: ALSA v: k5.15.8-200.fc35.x86_64 running: yes
           Sound Server-2: PulseAudio v: 15.0 running: no
           Sound Server-3: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel
           port: f000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           IF-ID-1: docker0 state: down mac: <filter>
           IF-ID-2: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A
Bluetooth: Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 bus-ID: 5-2:2
           Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 3.0 lmp-v: 5.1
Drives:    Local Storage: total: 476.94 GiB used: 103.25 GiB (21.6%)
           ID-1: /dev/nvme0n1 vendor: A-Data model: SX8200PNP size: 476.94 GiB temp: 36.9 C
Partition: ID-1: / size: 360 GiB used: 103.23 GiB (28.7%) fs: btrfs dev: /dev/nvme0n1p6
           ID-2: /boot/efi size: 1022 MiB used: 13.8 MiB (1.4%) fs: vfat dev: /dev/nvme0n1p5
Swap:      ID-1: swap-1 type: partition size: 10.09 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p7
           ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:   System Temperatures: cpu: 39.0 C mobo: 31.0 C gpu: amdgpu temp: 36.0 C
           Fan Speeds (RPM): cpu: 941 mobo: 603
           Power: 12v: N/A 5v: N/A 3.3v: N/A vbat: 3.07
Info:      Processes: 380 Uptime: 19m Memory: 13.56 GiB used: 2.87 GiB (21.2%) Init: systemd runlevel: 5 Compilers:
           gcc: 11.2.1 Packages: 10 note: see --pkg Shell: Zsh v: 5.8 inxi: 3.3.09

pw-top during playing video and doing speedtest

I also changed Bluetooth Adapter to USB 3.2 port on the back of the PC and not using mouse at the same time.
When I am screen-recording during speedtest , audio stuttering happened.
But the screen-record video doesn’t happen audio stuttering.

Since you’re using snd_hda_intel driver, you could check:

cat /sys/module/snd_hda_intel/parameters/power_save


cat /sys/module/snd_hda_intel/parameters/power_save_controller

If it said 1 and Y respectively, you could disable it with modprobe by createng file inside /etc/modprobe.d/mycustom.conf and add below config:

options snd_hda_intel power_save=0
options snd_hda_intel power_save_controller=N

Reboot your system and test it.

Found other possible way. Open Gnome System Monitor, if you’re using Gnome or other equivalent, there find wireplumber right click, select Change Priority, change it from normal to Very High. Usually anything related sound process will on very high priority and I don’t know why wireplumber set to normal, only pipewire set to very high by default.

Sorry for late reply.
Thanks I solved using this method.

1 Like