Background noise in laptop mic

I’m not sure when this started, probably sometime in August, but often when I join a video call on Teams or Zoom (both flatpak), others say there is a loud static noise in the background, making me inaudible. Sometimes it isn’t too bad, and I can go ahead with the call, but at other times it doesn’t work at all.

When I do a test call on Teams, I can hear the static in the recording, but not as bad as others seem to hear on the other end. I have no idea how to test or debug this. Any ideas anyone?

$ uname -r
$ inxi -A
Audio:     Device-1: Intel Comet Lake PCH-LP cAVS driver: snd_hda_intel 
           Device-2: Harman JBL Pebbles type: USB driver: hid-generic,snd-usb-audio,usbhid 
           Device-3: DisplayLink Dell Universal Dock D6000 type: USB driver: cdc_ncm,snd-usb-audio 
           Sound Server-1: ALSA v: k5.14.11-200.fc34.x86_64 running: yes 
           Sound Server-2: PipeWire v: 0.3.38 running: yes

I am using the built-in mic of my laptop, a Dell Latitude 7410.

I haven’t quite solved why the problem is happening, probably a gain setting somewhere. But I did figure out a workaround. When I was using my earphones, Fedora was still choosing the internal mic instead of the mic in my earphone. I found that I can force it to use my earphone mic as input from the “Input Devices” tab in pavucontrol. Hopefully this helps someone.