Ansible Logging Error on Fedora 38


I started experimenting with Ansible a few days ago under Fedora 37. I can’t say which Ansible, nor which Python version I used, because I didn’t have to worry about that, it just worked.

Now I’ve updated to Fedora 38 and Ansible still basically works, in the sense of “it configures the target”. But the output on the host is filled with an error message, to which I can’t find anything online.
It throws the corresponding error after each task (I’m only including the output of one task including error message here, but that’s what it looks like for each task and also the summary at the end):

Message: 'TASK [container : Mosquitto-Container anlegen] ***************************************'
Arguments: ()
ok: [containership]
--- Logging error ---
Traceback (most recent call last):
  File "/usr/lib64/python3.11/logging/", line 1114, in emit
  File "/usr/lib64/python3.11/logging/", line 1094, in flush
OSError: [Errno 5] Eingabe-/Ausgabefehler
Call stack:
  File "/usr/bin/ansible-playbook", line 8, in <module>
  File "/usr/lib/python3.11/site-packages/ansible/cli/", line 228, in main
  File "/usr/lib/python3.11/site-packages/ansible/cli/", line 647, in cli_executor
    exit_code =
  File "/usr/lib/python3.11/site-packages/ansible/cli/", line 144, in run
    results =
  File "/usr/lib/python3.11/site-packages/ansible/executor/", line 190, in run
    result =
  File "/usr/lib/python3.11/site-packages/ansible/executor/", line 333, in run
    play_return =, play_context)
  File "/usr/lib/python3.11/site-packages/ansible/plugins/strategy/", line 258, in run
  File "/usr/lib/python3.11/site-packages/ansible/plugins/strategy/", line 806, in _wait_on_pending_results
    results = self._process_pending_results(iterator)
  File "/usr/lib/python3.11/site-packages/ansible/plugins/strategy/", line 151, in inner
    results = func(self, iterator, one_pass=one_pass, max_passes=max_passes)
  File "/usr/lib/python3.11/site-packages/ansible/plugins/strategy/", line 749, in _process_pending_results
    self._tqm.send_callback('v2_runner_on_ok', task_result)
  File "/usr/lib/python3.11/site-packages/ansible/utils/", line 41, in inner
    return func(*args, **kwargs)
  File "/usr/lib/python3.11/site-packages/ansible/executor/", line 450, in send_callback
    method(*new_args, **kwargs)
  File "/usr/lib/python3.11/site-packages/ansible/plugins/callback/", line 106, in v2_runner_on_ok
    self._display.display(msg, color=color)
  File "/usr/lib/python3.11/site-packages/ansible/utils/", line 316, in display
    logger.log(lvl, msg2)
Message: 'ok: [containership]'
Arguments: ()

I’ve already uninstalled and then reinstalled Ansible, tried updating Python and I’ve also gone through the obligatory reboot.

I am using the following versions:

└─$ ansible --version                                      
ansible [core 2.14.5]
  config file = /home/user/Programmieren/ansible/ansible.cfg
  configured module search path = ['/home/user/.ansible/plugins/modules', '/usr/share/ansible/plugins/modules']
  ansible python module location = /usr/lib/python3.11/site-packages/ansible
  ansible collection location = /home/user/.ansible/collections:/usr/share/ansible/collections
  executable location = /usr/bin/ansible
  python version = 3.11.3 (main, Apr  5 2023, 00:00:00) [GCC 13.0.1 20230401 (Red Hat 13.0.1-0)] (/usr/bin/python3)
  jinja version = 3.0.3
  libyaml = True


└─$ python --version    
Python 3.11.3

OS: Fedora Linux 38 (Workstation Edition) x86_64

I hope someone of you has an idea, because the whole thing is already very annoying and confusing with 10 tasks.