After accidentally pressing restart during upgrade: "Oh no! Something has gone wrong. A problem has occurred and the system can't recover. Please log out and try again."

My system fails to log in while upgrading from 38 to 39(By mistake press the restart). Now entering the login password, I see a white screen like the following:

Oh no! Something has gone wrong.
A problem has occurred and the system can’t recover.
Please log out and try again.

Welcome to Fedora @sbhar

Please test this as you use a Nvidia GPU:

I did that, but it’s not the same problem either.

If you pressed restart via the Power button on your Computer while the update was going, I guarantee you have broken packages on the system.

Also, Please tell us what GPU, and computer spec is. This can help trouble shoot the issue.

Are you comfortable going back to a LiveUSB and attempting to fix the system from there? There will need to be several things you need to do to attempt to rebuild your system and other commands you could run to check system packages.

Yes, Please assist me

Please reply

Patience please!

We are not paid to respond instantly. Participants here are volunteers and assist as time permits, often in free time, possibly even while at work somewhere.

Sorry everyone, I’m in the Public Library, had to move from where I was.

I honestly believe you have broken packages on the system, so what i would do is clean up the update, and run a distro sync both using dnf.

Here we go :

  1. Open a terminal and find the partition where your Fedora system is installed. Typically, this is the root partition /. You can use the lsblk or fdisk -l command to list all available partitions and identify your root partition. Once you identify the root partition (let’s assume it’s either /dev/sdXn where “X” is the drive letter and “n” is the partition number or or /dev/nvme0nX), mount it to /mnt

mount /dev/sdXn /mnt

  1. let’s Bind mount some directories just in case :
    sudo mount --bind /dev /mnt/dev
    sudo mount --bind /proc /mnt/proc
    sudo mount --bind /sys /mnt/sys

  2. sudo dnf --installroot=/mnt clean all
    then
    sudo dnf --installroot=/mnt distro-sync

Let’s us know how it goes !

How to fix the mount point does not exist error at bind

go straight to # 3 , now that your /dev/sda4 is mounted to /mnt

  • sudo dnf --installroot=/mnt clean all
    then
    sudo dnf --installroot=/mnt distro-sync
1 Like

sudo dnf --installroot=/mnt clean all

It looks like you typed “clear” not clean

Okay sorry for that, But It’s still unable to detect the release version

It looks like there are mismatched packages,

Go ahead with sudo dnf --installroot=/mnt distro-sync

pointing to the same

You could try this again? sudo dnf --installroot=/mnt distro-sync --releasever=39 this include the Release you are upgrading to, which is what the command was asking you to add.
Using --best or --allowerasing are options for you as well.

If that does not work, Try these commands.

dnf upgrade --refresh
dnf install dnf-plugin-system-upgrade
dnf system-upgrade download --releasever=39

Ig adding --releasever=39 works, what to do next?

Repeat these commands :
sudo dnf --installroot=/mnt clean all --releasever=39
then

sudo dnf --installroot=/mnt upgrade --refresh add --best --allowerasing if needed.

Add the --releasever=39 flag please, that is what the error is telling you. My apologies for not adding that.

1 Like