5ghz connection not working

Hi, i have a problem with the 5ghz connection whe I’m trying to connect to it it gave me a limited connectivity and wifi symbol with ‘?’ after couple a seconds it connect with ‘!’ symbol next to it and being hang there like that, though 2.4ghz works fine, and 5ghz works on phones/laptop with windows 11/playstation perfectly, even on my laptop with windows works, i don’t know how to fix it i searched up alot and can’t get any useful solution here is what I can provide for information tell me if other thing you want
it also not working in the live usb
I’m on fedora 40 kde spin


Screenshot_20240617_201258


last screen shots the settings for the router


this too

Can you post the output of the ip address and ip route commands?

1 Like
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host noprefixroute 
       valid_lft forever preferred_lft forever
2: eno2: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 50:eb:f6:8e:5b:24 brd ff:ff:ff:ff:ff:ff
    altname enp0s31f6
3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether fe:ca:26:5f:b1:f5 brd ff:ff:ff:ff:ff:ff permaddr 2c:6d:c1:88:45:50
    altname wlp0s20f3
    inet 192.168.100.89/24 brd 192.168.100.255 scope global dynamic noprefixroute wlo1
       valid_lft 84324sec preferred_lft 84324sec
    inet6 fe80::827c:607d:42fd:496f/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

default via 192.168.100.1 dev wlo1 proto dhcp src 192.168.100.89 metric 600 
192.168.100.0/24 dev wlo1 proto kernel scope link src 192.168.100.89 metric 600

It looks like your IP settings are correct. Is your DNS working? Can you resolve hostnames to IP addresses? e.g. nslookup fedoraproject.org should return several IP addresses.

1 Like

No it give a ;; communications error to 127.0.0.53#53: timed out
and DNS seems not working
output of resolvectl :


while for 2.4ghz :

Well, now it seems to work after i connect to it again without any problem “for now”, I really don’t know why and what make it work ,I didn’t touch anything now actually, I tried a lot of commands the past three days like A LOT, but I missed up something in the settings I will fix it later as long as the wifi working I will try to restart to see if anything changed

another update i restart the laptop the wifi didn’t work as usual but I decided to restart the router the wifi getting work again, I don’t know exactly what happening but it works thanks for your time :saluting_face:, and I have another question this website suddenly get down it happend twice and can’t open it while every website works fine, is this something with the company provide me the Internet?

1 Like

A router is just another form of a computer with a dedicated purpose.

Sometimes rebooting the router may be needed just like your laptop or desktop pc. Things may be in cache there that need to be wiped out and the restart accomplishes that.

maybe that the problem, but I was having this problem like for a year ago when I was using linux on my old laptop and couldn’t fix it, anyway it works right now, thanks for the info. :saluting_face:

I had the same problem a couple of times today, it may be related to the Fedora infrastructure. Yesterday was fine though.

1 Like

Hi again nothing being fixed :classic_smiley:
image
the wifi can’t get the ip address it can’t connect to it at all
any more solutions?

If it sometimes works and sometimes doesn’t, it could be your router. Can you post the DHCP settings of your router (IP address range, default gateway, DNS server, etc.)? Also, if you set your router as a DNS server, does it have a reliable DNS service running?


this DHCP server settings

and this the DHCPV6 server
I hope that’s what you want, I don’t know a lot about this settings

But it’s working on windows and other devices
what make it to not working on linux even the 2.4ghz settings like 5ghz it doesn’t make sense to me i don’t have a lot of information
I will try a live usb on another laptop

On your first image, can you set the primary and secondary DNS servers to a well-known public DNS resolver? You can use Quad9 (9.9.9.9), Google (8.8.8.8), Cloudflare (1.1.1.1) or whatever you like.

I can’t it’s grayed locked

Can you disable getting DNS from DHCP and specify DNS servers on the connection profile? It should look similar to below picture.

image

1 Like

I tried but nothing work, Now I downloaded ubuntu and fedora workstation they both works, it seems the problem from fedora kde spin
I will just install fedora and install kde if i want
I wish I did this from the beginning, anyway thanks a lot for your time :saluting_face::white_heart:

1 Like