Zoom-window is black

Hi.
Not sure where you’re leading this to. As I wrote earlier, I have zoom working using their provided RPM. And had issues with flatpak version. That’s it.

I’ve tried fresh install F36 + zoom in wayland with nouveou driver and screen sharing was working fine. Then installing nvidia driver, sharing screen becomes black, so it looks like it’s something to do with nvidia driver. Interestingly enough that using zoom via Firefox, I was able to share Window/screen and clients saw it normally

Hi - I encountered the same problem on PopOS 22.04 running Nvidia520 (GTX 1070) and Gnome on Wayland today.

Black screens for both windows of Zoom as you described, and my logs consistently matched the pulseaudio section, Ignoring XDG_SESSION_TYPE=wayland on Gnome, and Sep 06 14:06:15 fedora Zoom.desktop[20420]: libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)

For me, setting the environment variable QT_QPA_PLATFORM=wayland in flat seal got Zoom running normally again.

I was also experiencing black screens in some menu’s of Zoom (flathub version). I’m on Fedora 37, Nvidia Geforce GTX 1070Ti (Driver version: 525.78.01 through rpmfusion).

I tried setting the enviroment variable QT_QPA_PLATFORM=wayland in Flatseal and this also worked for me.

Zoom is not super stable, but this is a definite improvement.

2 Likes

How did you setup this environment variable.
I’ve tried yesterday with updated F37, latest nvidia drivers, kernel and zoom 5.13.5, and it’s still black screen when sharing window in wayland, so I restarted with nouveou driver to be able to work

2 Likes

Here is a screenshot of the setting.

332fd4a09210341554556c0fac870c3352dee48c.png

1 Like

Zoom is known to have some problems when using wayland. I use xorg and have never had an issue with the black windows and using nvidia 1050 GPU.

Happens with Microsoft Teams too. Nvidia + Wayland (KDE) causes a black screen on start.

not sure where you setup up this. I have zoom installed via rpm, but I did add QT_QPA_PLATFORM=wayland in zoom.desktop file in /usr/share/applications to the Exec line, and sharing windows is a bit different, but still blank for clients

That was true, but it’s generally been working for a while now with Wayland but specifically on Gnome. It definitely still has issues with KDE and other DEs. It used to work by exploiting the screenshot API in Gnome, so Zoom basically could access your entire screen whenever it was running and not just what you specifically chose to share during sharing. When Gnome removed access to that way overpowered API, Zoom took several months to use the proper APIs they should have been using all along. They finally did, but continued to implement Gnome-specific methods. Zoom seems to crash within seconds to minutes using Wayland on KDE, but generally works fine now with the flatpak using Wayland on Gnome.

1 Like