Repo with latest version of the KDE Frameworks (5.61.0), KDE Plasma (5.16.4) and KDE Applications (19.08.0).

This is a companion discussion topic for the original entry at

hello, I just tested under virtualbox and fedora 31, the installation of kde 5.17 without problem. Only one little thing, fedora 31 was under the kernel 5.3.8, after the installation, I find myself under the kernel 5.3.7. On the other hand, when I run dnf upgrade on my hard installation of fedora 31, it does not propose to install kernel 5.3.7, so I guess I will stay in 5.3.8? Amazing this difference between virtualbox and non-virtualbox

Thank You


I installed without problem your version of kde 5.17.2 without problem under Fedora 31 (5.16.5).

A very big thank you for this update.

​Thanks! ​:grinning:

1 Like

No problem with the last update 19.08.3. Thank you


I am trying to use kwinft under fedora 33 beta. I have tried
dnf install --allowerasing kwinft && sudo dnf update
but I get a list of conflicts and the following packages skipped

Skipping packages with conflicts:
(add ‘–best --allowerasing’ to command line to force their upgrade):
kwin-common x86_64 5.20.0-2.fc33 2.5 M
kwin-common x86_64 5.20.1-1.fc33 2.5 M
kwin-libs x86_64 5.20.0-2.fc33 1.5 M
kwin-libs x86_64 5.20.1-1.fc33 1.5 M
kwin-lowlatency-common x86_64 5.20.0-2.fc33 2.5 M
kwin-lowlatency-common x86_64 5.20.1-1.fc33 2.5 M
kwin-lowlatency-libs x86_64 5.20.0-2.fc33 1.5 M
kwin-lowlatency-libs x86_64 5.20.1-1.fc33 1.5 M
libgcc x86_64 10.2.1-3.fc33 fedora 97 k
libkworkspace5 x86_64 5.19.5-1.fc33 110 k
libkworkspace5 x86_64 5.19.5-3.fc33 fedora 110 k
libkworkspace5 x86_64 5.20.0-1.fc33 111 k
libkworkspace5 x86_64 5.20.0-2.fc33 111 k
libkworkspace5 x86_64 5.20.0-3.fc33 111 k
libkworkspace5 x86_64 111 k
plasma-workspace-common x86_64 5.20.0-1.fc33 29 k
plasma-workspace-common x86_64 5.20.0-2.fc33 29 k
plasma-workspace-common x86_64 5.20.0-3.fc33 29 k
plasma-workspace-common x86_64 29 k
plasma-workspace-libs x86_64 5.20.0-1.fc33 2.1 M
plasma-workspace-libs x86_64 5.20.0-2.fc33 2.1 M
plasma-workspace-libs x86_64 5.20.0-3.fc33 2.1 M
plasma-workspace-libs x86_64 2.1 M
Skipping packages with broken dependencies:
kde-cli-tools x86_64 5.20.1-1.fc33 940 k
kwin-lowlatency-x11 x86_64 5.20.0-2.fc33 140 k
kwin-lowlatency-x11 x86_64 5.20.1-1.fc33 140 k
kwin-x11 x86_64 5.20.0-2.fc33 140 k
kwin-x11 x86_64 5.20.1-1.fc33 140 k
plasma-lookandfeel-fedora noarch 1.1 M
plasma-workspace x86_64 5.19.5-1.fc33 5.4 M
plasma-workspace i686 5.19.5-3.fc33 fedora 5.4 M
plasma-workspace x86_64 5.19.5-3.fc33 fedora 5.4 M
plasma-workspace x86_64 5.20.0-1.fc33 6.6 M
plasma-workspace x86_64 5.20.0-2.fc33 6.6 M
plasma-workspace x86_64 5.20.0-3.fc33 6.6 M
plasma-workspace x86_64 6.6 M
plasma-workspace-doc noarch 2.4 M
plasma-workspace-wayland x86_64 29 k
plasma-workspace-xorg x86_64 34 k
sddm-breeze noarch 935 k

Transaction Summary

Skip 40 Packages

Is this expected?

What I am trying to do is use KDE on a ThinkPad L15 AMD Gen1 with a Lenovo 4K monitor but so far I can only use X11 plasma. If I try Wayland it tries to start KDE and then restarts the session.

Even in X11 plasma if I change the global scale it corrupts the external monitor and I can only get the screen back by running:

rm -rf .local/share/kscreen

I’m happy to try stuff / supply logs etc to get this working.

Many thanks


Missing the file “kwinft-wayland-nvidia” for version 5.21.3 of plasma kde . Would it be possible to add it
and kwinft ?

Thank you for your work