xxmitsu/mesa-and-llvm-git

This repo is a modified version of che-mesa, triggered to be rebuilt every few hours if code update is detected.


This is a companion discussion topic for the original entry at https://copr.fedorainfracloud.org/coprs/xxmitsu/mesa-and-llvm-git/

You converted the specfile to the template Oct 06 2019 (this date figurated at changelogs) and use it to generate the actual script. Can you please share your toolkit to generate the actual script?
Sometimes I needed for testing apply patches over the master branch of Mesa.

Hi,
To be easy for you: fork mesa on gihub, add as many patches you want to test on your fork, then use the spec to point to your repo and your head commit sha.

I liked the previous version of the spec file more because it was possible to build the latest version of mesa without making changes in the spec file by simply executing these 4 commands from the console:

$ spectool -g -R mesa.spec
$ rpmbuild -bs mesa.spec
$ mock -r fedora-rawhide-x86_64 --rebuild ~/rpmbuild/SRPMS/mesa-<auto complete>.src.rpm
$ mock -r fedora-rawhide-i386 --rebuild ~/rpmbuild/SRPMS/mesa-<auto complete>.src.rpm

Now, as is clear from the changelog, it was decided to generate the spec file with an external script in order to solve the problem of unsynchronizing architecture versions during build, but judging by the errors, this problem was not solved:

Example 1: https://pastebin.com/bH36Djsa
Example 2: https://pastebin.com/8HwMVJxE

I see that you are using fedora rawhide.
Since a week ago, there is a problem with fedora-rawhide-i686 container, so any build fails with

/usr/bin/tar: mesa-a3dc975ee7964d84b4df500751695e6d2cbfcc85/src/mesa/drivers/dri: Cannot utime: Operation not permitted
/usr/bin/tar: mesa-a3dc975ee7964d84b4df500751695e6d2cbfcc85/src/mesa/drivers: Cannot utime: Operation not permitted
/usr/bin/tar: mesa-a3dc975ee7964d84b4df500751695e6d2cbfcc85/src/mesa: Cannot utime: Operation not permitted
/usr/bin/tar: mesa-a3dc975ee7964d84b4df500751695e6d2cbfcc85/src: Cannot utime: Operation not permitted
/usr/bin/tar: mesa-a3dc975ee7964d84b4df500751695e6d2cbfcc85: Cannot utime: Operation not permitted
/usr/bin/tar: Exiting with failure status due to previous errors

Unfortunately, there’s nothing I can do on my side, until fedora copr solves this issue.
Other builds are experiencing the same issue.

Fedora rawhide builds had also experienced stability issues in past. I guess this is the price to pay if someone wants to go bleeding edge.

1 Like

I don’t know how looks your build script but for keeping in the consistent state repo it enough push changes only if all architectures was builded successfully. I suppose fedora copr currently doesn’t have this feature so a good starting point may be to fill feature request for such feature.

Did you know is possible build mesa without Clang?
I found in spec file that with_opencl variable could control dependence from Clang.


I supposed setting %global with_opencl 0 would be enough for it, but in reality, it isn’t working.

After changing 1 to 0 in with_opencl variable I meson said an error message meson.build:719:2: ERROR: Dependency "libclc" not found, tried pkgconfig

So my question is open, is possible to compile mesa without Open CL and Clang or not?