Xprop issue when examining terminal window

I have tried to use xprop to examine a terminal window like this: xprop -name MyTerm.
Xprop can’t find that window even though it is named as “MyTerm” and desktop does recognize it under that name. Then I have tried over -id option, but I can’t find the id of that specific terminal window (I have tried to use xprop -root _NET_CLIENT_LIST_STACKING, xprop -root _NET_ACTIVE_WINDOW and xwininfo -root -tree).
Notice: If I use a plane xprop or xwininfo with mouse selection of window then the command doesn’t respond on mouse click (even mouse cursor appearance stay the same in “classic pointer”).
The terminal is gnome-terminal (v3.36)

I’m new to Fedora so I wanna know is that normal to Fedora or am I missing something because I tried the same thing on Mint and Ubuntu and everything works fine.

Hi Petar and welcome to the forum.

I suspect your session is running on Wayland, not X and that’s why xprop and xwininfo don’t work with your windows. See this for some info.
GNOME’s Looking Glass might be able to give the information you want.

1 Like

Thank you for your reply. Can I somehow switch to X11?

I have found the solution:

  1. Open /etc/gdm/custom.conf and uncomment WaylandEnable=false .
  2. Add the following line to the [daemon] section:
  3. Save the custom.conf file.
1 Like