Xorg crashes on fresh install of Fedora 30

Hello everybody.

I installed Fedora 30 a couple of days ago. Unfortunately, I keep having an issue with xorg crashes once or twice a day. Basically, my screen goes to black and I’m thrown back to the log-in screen. The Problem Reporting Tool gives me two separate “xorg-x11-server quit unexpectedly” entries every time this happens, one “Misbehavior” and one “Application Crash”. Here are the details for both of these entries:

I’m currently on the default drivers, and, believing this may be a driver-related issue, I wanted to give the nonfree drivers for Nvidia a try (I have a GeForce GTX 970), but after enabling the repository in the Software application, I’m still not getting a Hardware Drivers category under Add-ons, and I’m not sure why.

I would be grateful for any advice.

1 Like

Did you try this method?


Thank you, that driver install seems to have worked. I’ll keep an eye out for any further crashes, if I don’t get any, I’ll mark this as solved.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.