Wrong resolution after nvidia driver. Showing two monitors

Hello guys!
I’m having an issue with my monitor it is 1680 X 1050. It was working fine before a installed the nvidia driver, now I don’t even understand what is happening but in the gnome settings it shows up like two monitors but I have only one, so I disabled the one that doesn’t exist but even doing that the closest resolution that I can choose is 1920 X 1080, but I’d like to use the real resolution of my monitor, this one is too big.
Also I’m having another issue that I don’t know if there is something to do with the first one but the resolution on the lockscreen is much smaller so the screen is all stretched and wide.
I don’t know if helps but my GPU is a GT1030.
I’d really appreciate if someone could help me.

If nouveau meets your needs, NVIDIA drivers are high maintenance and you may have much better ways to use your time.

A similar report in the past couple days was solved by adding an option to the kernel command line Removing Fake Unknown Display on Fedora 38.

As for the screen resolution: Xorg creates a region large enough for both “monitors”.

Thank you for your response.
Sorry, I’ve meant to say that the resolution was working fine before the drivers, but the overall performance is much better with it.
So I tried adding these lines to grub but it says that file doesn’t exist, I tried adding just one, then just the other, the two, but it’s always the same return. Any idea what could it be?
Thank you!

Edit: I looked the exact error

error: …/…/grub-core/kern/fs.c:170:invalid file name ‘nvidia-drm.modeset=1’.

I don’t know if helps but it’s there

The linux grub2 bootloader is used by many linux distros.
If you arent sure how to edit the kernel command-line in grub2, have a look at How to access and use your linux distribution’s boot loader.

Please show us your current command line by running cat /proc/cmdline.

If the new arguments work Grub menu management tells you how to make permanent changes that will also be applied to updates.

Sorry for taking too much time for the response.
I managed to put these lines on grub, and the unknown monitor is not appearing anymore. But there’s no option for 1680 x 1050. I’ve tried adding it with xrandr but it didn’t work, the command says the resolution has been added, but it doesn’t show in gnome settings.
Any idea? Thank you very much.

Most monitors any more are 1920x1080 or larger. Even my laptop uses that resolution and some are higher – Like 2k or 4k resolution.

Are you sure you need the 1680x1050? That seems a strange value.
This is what is available on my desktop.

$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1600mm x 900mm
   1920x1080     60.00*+  59.94    29.97    23.98  
   4096x2160     59.94    29.97    25.00    24.00    23.98  
   3840x2160     59.94    29.97    25.00    23.98  
   1360x768      60.02  
   1280x1024     60.02  
   1280x720      60.00    59.94  
   1152x864      60.00  
   1024x768      60.00  
   800x600       60.32  
   720x480       59.94  
   640x480       59.95    59.94    59.93  

My GPU is capable of 4k+ (3840x2160) but my monitor will not properly support that with viewable size. I would need a 52 inch or larger monitor to be comfortable with that resolution.

Please provide more details (make and model) of your monitor and the type of connection you use. Are you using a KVM switch? Some older monitors and KVM switches provide incorrect Extended Display Identification [meta]Data (EDID). As @computersavvy notes, 1680x1050 is no longer widely used, so it may be that it is not included in the defaults when the driver doesn’t handle the EDID your setup provides. You can check for warnings and error messages as in the following example (from a system that is working properly):

$ journalctl -b -g EDID
Jul 13 15:24:33 h /usr/libexec/gdm-x-session[4236]: (II) modeset(0): EDID for output HDMI-1
Jul 13 15:24:33 h /usr/libexec/gdm-x-session[4236]: (II) modeset(0): EDID for output HDMI-3

Right, so I’m sure my monitor is 1680x1050, it even shows a message saying that 1920x1080 is not recommended and says the proper resolution, which is the one I said. My monitor is an old samsung, I don’t know the exact model, it uses VGA and I have to use an adaptor for hdmi. But the thing that I find odd is that without the nvidia drivers the system recognize this resolution with no problem, and I really don’t think is the age the problem cause it even shows some more unusual resolution in the settings, like 1024x768.

here is the output of that command:

jul 19 22:49:13 microdoelo popcorn-time.desktop[18897]: [18897:18897:0719/224913.718151:ERROR:edid_parser.cc(102)] Too short E>
jul 19 22:49:32 microdoelo popcorn-time.desktop[18897]: [18897:18897:0719/224932.580328:ERROR:edid_parser.cc(102)] Too short E>
jul 19 23:46:31 microdoelo popcorn-time.desktop[18897]: [18897:18897:0719/234631.577796:ERROR:edid_parser.cc(102)] Too short E>
jul 19 23:46:35 microdoelo popcorn-time.desktop[18897]: [18897:18897:0719/234635.444186:ERROR:edid_parser.cc(102)] Too short E>

The journalctl -b -g EDID messages in teh post are truncated, but an educated guess is: Too short EDID.

kernel.org admin-guide EDID lists a number of potential EDID problems, and states:

As a remedy for such situations, the kernel configuration item CONFIG_DRM_LOAD_EDID_FIRMWARE was introduced. It allows to provide an individually prepared or corrected EDID data set in the /lib/firmware directory from where it is loaded via the firmware interface. The code (see drivers/gpu/drm/drm_edid_load.c) contains built-in data sets for commonly used screen resolutions (800x600, 1024x768, 1280x1024, 1600x1200, 1680x1050, 1920x1080) as binary blobs, but the kernel source tree does not contain code to create these data.

Fedora has:

% grep -F EDID /lib/modules/6.3.12-200.fc38.x86_64/config

I assume “without NVIDIA” means either integrated graphics or nouveau, so it seems that NVIDIA drivers don’t use the “built-in data sets”, but the Fedora drivers do use them.

Yes I mean nouveau, sorry. I think I understood the part of the article that you quoted, it really is a good guess that nvidia drivers don’t use this config settings, but how can I set this “built-in data sets”?

I’ve entered grep -F EDID /lib/modules/6.3.12-200.fc38.x86_64/config and the output was exacly like the one that you’ve sent.

That is a huge monitor, like a very big screen TV.

Not really super large, but not a desktop monitor either. A 42 inch TV with only 1920x1080 resolution default. It is mounted on the wall above my desk.

Actually it’s not in mm it’s in pixels, It’s 1600 pixels by 900 pixels.

Not quite true. Look up the specs as ppi (pixels per inch) which is where the 1080p resolution is based.

My screen measures 34.5 inch X 19 inch (~42 inch diagonal) ( or ~876 X ~482 mm) Which is about half the 1600 X 900 mm noted.

When I set it to 4k resolution the pixels are equivalent to the noted 1600X900 but in a screen half the size in each dimension

As far as I understand, 1080p just means 1080 scan lines if using the old television nomenclature. You can have 1080p on everything from smart phones to big tv screens. That is, if https://en.wikipedia.org/wiki/1080p is to be believed. Anyway, that has nothing to do with the problem in this thread.

I stand corrected, but still the noted 1600x900 is not in pixels but actually related to mm as noted with the reported resolution of my monitor.

Hey actually I ran journalctl -b -g EDID again and it gave me no output, just says “no entry”, and a realized that the previous output was just from an app that I had open at that moment. Sorry

It isn’t clear to me if the Gnome Settings Displays and xrandr still offer resolutions beyond the capacity of your monitor. Are you happy with the current state of your system?

Actually Gnome Settings offer resolutions beyond the capacity of my monitor, so it is that I’m using 1920 x1080 even the maximum capacity of my monitor being 1680 x 1050. And no I’m not too happy with the state of my system cause I’d like to use the true resolution of my monitor but it’s not available in the settings.

Do circles appear oval due to incorrect aspect ratio?

You may be able to find a correct EDID for your monitor on the vendor’s site and then use
NVIDIA: How to specify a custom EDID.