Windows Update/New BIOS clobbers Grub, how to restore?

Hello, I dual boot and occasionally Windows updates will clobber Grub2. So after updates for Windows machine directly enters Windows and does not pause at Grub selection. My mfr only distributes BIOS updates for installation under Windows. Almost ALWAYS this clobbers Grub2 menus at startup.
Until now simply selecting linux partition on boot order screen has restored Grub. But not this time.

I use fedora 34 installed as btrfs mount point / A separate partition for /boot. The System EFI partition is mounted to /boot/efi. And in addition btrfs mount point on / is luks encrypted.

The recovery recipe here: Bootloading with GRUB2 :: Fedora Docs does NOT work for luks encrypted volume. cryptsetup only worked uising the luksOpen option. Simple mount commands worked. Mounting with --bind or other options did not succeed.

How can grub2 be reinstalled reactivated after Windows clobbers access to Grub boot loader?
[ I gave up and performed hard reinstall from anaconda installer. It works for me now.]


1 Like