Windows maximize over bottom edge of the screen on Nvidia and X11 (desktop is bigger than monitor)

I have a problem after installing Nvidia drivers. Everything went super smooth, I installed all Nvidia related packages from the software centre plus:

$ sudo dnf install kernel-devel xorg-x11-drv-nvidia akmod-nvidia

$ sudo dnf install xorg-x11-drv-nvidia-cuda

$ sudo dnf install vdpauinfo libva-vdpau-driver libva-utils ffmpeg

$ reboot

So all looks good after reboot except the fact that the desktop is bigger than my screen on the bottom. If i maximize any window, the bottom part like status bar, subtitles on netflix … don’t apear on the screen.

I am using Fedora 33 Workstation (with Gnome, the standard flavour) on a Nvidia GTX 660.
I had the same ishue on Fedora 32 after installing Nvidia. On wayland everything is ok.
The monitor is an Acer XB271HU 27". In Nvidia settings, i have all the correct values, like: 2560x1440 rezolution, 120 Hz. The monitor is connected thought a display port.

It seems like the rezolution displayed is bigger than the monitor or something. It is becoming very annoying and i can’t find any solutions on google.

Please help.

Did you also install kernel-headers?

Is that resolution and refresh correct for the monitor? You said you have it set for 120hz refresh, but the specs show that resolution at 144hz refresh when using DP.

1 Like

kernel-headers is already installed

I tried to connect through HDMI. The desktop size it’s ok, but in nvidia-settings I have only 60 Hz.

On DP, 120 is the max. value I can choose. If I remember correctly, in windows I had only 120 Hz also (i don’t have windows installed anymore to verify that)

The output of xrandr seems a little bit weird to me, the panning is bigger than the resolution:

$ xrandr
Screen 0: minimum 8 x 8, current 2560 x 1440, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 598mm x 336mm panning 2560x1567+0+0
    2560x1440     59.95 + 120.00*   99.95    84.98    23.97
    1024x768      60.00
    800x600       60.32
    640x480       59.94

Is this normal?
I tried:

$ xrandr --output DP-1 --rate 120 --mode 2560x1440 --fb 2560x1440 --panning 2560x1440

But the output of xrandr doesn’t change.
I don’t get any panning in the way that if I touch the bottom of my screen, the image moves, I am locked on a 2560x1440 resolution, except the fact that maximized windows are bigger only on the bottom side

Let’s abstract your issue: the aspect ratio, the display refresh rate are composed of technical terms: the GPU, the driver, the cable an so on. You will get only the result of this core components. Software switches are often used for fine-tuning. Check your cables and try different ports. Don’t forget the scaling factor and use only values which are supported by your monitor(look at your settings menu!). I have heard many crazy things about different distros concerning HiDPI monitor resolution, scaling etc. Try for testing purposes an other commercial distro (e.g. Ubuntu) to see if things get better. Refresh rate is not only the most important thing. Try your TV as a monitor und if it works you have a hint what is going wrong. :grinning:

heliosstyx and computersavvy I really appreciate taking your time to help.
But the cables can’t be the issue because on windows 10 and Wayland, DP works perfectly.

heliosstyx, after I had my first response I felt like I didn’t do my research well enough so I searched about all the settings in the monitor OSD, did some changings but no success. Look, this is the result of xrandr on HDMI:

$ xrandr
Screen 0: minimum 8 x 8, current 2560 x 1440, maximum 16384 x 16384
DVI-I-0 disconnected (normal left inverted right x axis y axis)
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 597mm x 336mm
   2560x1440     59.95*+
   1920x1080     59.94    50.00
   1280x720      59.94    50.00
   1024x768      60.00
   800x600       60.32
   720x576       50.00
   720x480       59.94
   640x480       59.94    59.93
DP-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)

I have a laptop with a GTX 1060 Mobile, Fedora 32 installed, Nvidia drivers installed the same way as on my workstation and everything is perfect on my laptop.

I had the exact same problem on my workstation in Fedora 32 after I installed Nvidia. I thought that after I will upgrade, things will be better, but it seems not. So the problem is in the nvidia settings or the driver. But I think it can be solved. It lies in that panning/ viewport size or what ever… I am a noob in linux still

Okay. This facts show that your hardware works fine. Wayland and Windows are a good evidence that your technical infrastructure works flawless. I am sure now that the driver and/or kernel have a little malfunction and I suggest you to wait for new driver/kerne versions. Have you looked at your system-information, is the NVidia-driver really loaded (not nouveau!). I assume you have only one built-in graphics card, you need driver 455.38 (look at driver section).

Yes, I have only one video card (i am not taking into consideration the CPU integrated one i7-3770K).
I can confirm that nvidia 455.38 is loaded and used.

$ lspci -nnk | grep -i vga -A3 | grep 'in use'
    Kernel driver in use: nvidia
$ modinfo $(modprobe --resolve-alias nvidia)
    filename:       /lib/modules/5.8.18-300.fc33.x86_64/extra/nvidia/nvidia.ko
    alias:          char-major-195-*
    version:        455.38
    supported:      external
    license:        NVIDIA
    srcversion:     1240E078F6A01F945F04278
    alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
    alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
    retpoline:      Y
    name:           nvidia
    vermagic:       5.8.18-300.fc33.x86_64 SMP mod_unload
    parm:           NvSwitchRegDwords:NvSwitch regkey (charp)
    parm:           NvSwitchBlacklist:NvSwitchBlacklist=uuid[,uuid...] (charp)
    parm:           nv_cap_enable_devfs:Enable (1) or disable (0) nv-caps devfs support. Default: 1 (int)
    parm:           NVreg_ResmanDebugLevel:int
    parm:           NVreg_RmLogonRC:int
    parm:           NVreg_ModifyDeviceFiles:int
    parm:           NVreg_DeviceFileUID:int
    parm:           NVreg_DeviceFileGID:int
    parm:           NVreg_DeviceFileMode:int
    parm:           NVreg_InitializeSystemMemoryAllocations:int
    parm:           NVreg_UsePageAttributeTable:int
    parm:           NVreg_RegisterForACPIEvents:int
    parm:           NVreg_EnablePCIeGen3:int
    parm:           NVreg_EnableMSI:int
    parm:           NVreg_TCEBypassMode:int
    parm:           NVreg_EnableStreamMemOPs:int
    parm:           NVreg_EnableBacklightHandler:int
    parm:           NVreg_RestrictProfilingToAdminUsers:int
    parm:           NVreg_PreserveVideoMemoryAllocations:int
    parm:           NVreg_DynamicPowerManagement:int
    parm:           NVreg_DynamicPowerManagementVideoMemoryThreshold:int
    parm:           NVreg_EnableUserNUMAManagement:int
    parm:           NVreg_MemoryPoolSize:int
    parm:           NVreg_KMallocHeapMaxSize:int
    parm:           NVreg_VMallocHeapMaxSize:int
    parm:           NVreg_IgnoreMMIOCheck:int
    parm:           NVreg_NvLinkDisable:int
    parm:           NVreg_EnablePCIERelaxedOrderingMode:int
    parm:           NVreg_RegisterPCIDriver:int
    parm:           NVreg_RegistryDwords:charp
    parm:           NVreg_RegistryDwordsPerDevice:charp
    parm:           NVreg_RmMsg:charp
    parm:           NVreg_GpuBlacklist:charp
    parm:           NVreg_TemporaryFilePath:charp
    parm:           NVreg_AssignGpus:charp

When I started my computer today, my monitor displayed a no signal input (was connected over HDMI), the only way was to connect it over DP :frowning:

Can you help me revert back to Wayland? I couldn’t find any clear instructions on google because it seems everyone wants to move from Wayland to Xorg :joy:

This a how spacemacs looks like it it’s not maximized

and if I maximize, all that bottom part is way down off the screen

I just booted a usb with Pop!_OS 20.10 with Nvidia preinstalled and I have the same problem :pensive:
Pop!_OS with Gnome 3.38.1 and Nvidia version: 455.38

If you want to get back Wayland the easiest way is to reinstall Fedora 33. If I remember it right Wayland does not work together with proprietary nvidia-driver installed. I am not using Gnome now. Removing the nvidia-driver manually again and reactivate wayland is a lit bit complicated. Perhaps another member in this forum knows how to do it right.