Windows guest screen goes black when i try to use Intel GVT-g passthrough in silverblue?

I have a dedicated GPU (980Ti) and an oboard GPU (via i7 6700k), and a single monitor. I wanted to passthrough my onboard GPU to one of my VMs, and i have fedora 36 silverblue.

Followed this guide:

And successfully did every step, but when i boot my VM after changing the XML, the screen is black. Note that in my bios setting, i set the primary display to PCI (aka my NVIDIA gpu) but also tried the CPU graphics as primary as well, neither helped. I also set the vRAM of my onboard GPU to 1024MB (DVMT pre allocated), still didn’t help. The only difference between me and that guide is that i used the i915-GVTg_V5_4 (because it supports higher resolutions it seems)

I also tried the following guide:

And tried different suggestions there, including trying every possible way of getting and displaying the iGPU output mentioned there, but neither worked, most of them just gave errors when i tried to run the VM. Both the NVIDIA EGL and GTK display failed with errors (for example i get “OpenGL is not supported by the display” in the case of GTK display).

How can i find out what is causing this and fix it?

Is this happening because of restrictions (SElinux rules) that exist in silverblue? Note that when the VM boots, i can get some sound outputs, which shows the VM is actually booted successfully.