Windows entry missing in grub menu

I have Windows on a raid volume and installed Fedora 39 on a separate SSD. The grub menu does not have a Windows option for boot. I can boot to either environment by using the BIOS boot settings, but not through grub. I’ve tried running os-prober without success. EFIbootmgr sees both OS but grub can’t find it. Is there a way to manually configure the menu to allow Windows to be an option?

When you booted with Fedora you could try the tool grubby.

And give also a check here:

Thanks for the suggestion. I tried running grubby command previously and that didn’t solve the problem. I “fixed”, or more like worked around, the issue by doing the following:

  1. Disabled the RAID controller in BIOS and booted back into Fedora. This works in RAID 1, but not sure if other RAID levels will corrupt the data or even work.

  2. Once in Fedora, run command: sudo os-prober. Windows Boot Manager appeared for both drives.

  3. Run command: sudo grub2-mkconfig -o /boot/grub2/grub.cfg to update grub.

  4. Reboot and check to see if Windows Boot Manager appears in menu

  5. Boot into BIOS and re-enable RAID controller.

I was able to successfully boot into Fedora and Windows from the grub menu after this.