Windows 11 boot not showing up on BIOS or GRUB but the Windows is still there

I installed Fedora 39 with KDE today, and there must be a mistake at dual boot. I can’t reach to windows anymore, both on BIOS or GRUB. I tried to recover it from windows flash USB through diskpart, but it didn’t worked. Here’s some info about the system. The motherboard is B450m S2H.

mckn@fedora:~$ lsblk
sdb           8:16   1   7,2G  0 disk 
zram0       252:0    0     8G  0 disk [SWAP]
nvme0n1     259:0    0 465,8G  0 disk 
├─nvme0n1p1 259:1    0   100M  0 part 
├─nvme0n1p2 259:2    0    16M  0 part 
├─nvme0n1p3 259:3    0 443,4G  0 part /run/media/mckn/58A07F02A07EE5C2
├─nvme0n1p4 259:4    0   1,2G  0 part 
├─nvme0n1p5 259:5    0     1M  0 part 
├─nvme0n1p6 259:6    0     1G  0 part /boot
├─nvme0n1p7 259:7    0    19G  0 part /home
│                                     /
├─nvme0n1p8 259:8    0   575M  0 part 
└─nvme0n1p9 259:9    0   569M  0 part 

mckn@fedora:~$ lsblk -f
NAME      FSTYPE FSVER LABEL                   UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
sdb       udf    1.02  CCCOMA_X64FRE_TR-TR_DV9 fd6280004d532055                                    
zram0                                                                                              [SWAP]
│         vfat   FAT32                         94E2-4544                                           
│         ntfs                                 58A07F02A07EE5C2                      217,8G    51% /run/media/mckn/58A07F02A07EE5C2
│         vfat   FAT32                         7ED7-CDE8                                           
│         ext4   1.0                           dbc2931d-67e8-4401-be75-3710cfd3a1a6  637,2M    28% /boot
│         btrfs        fedora                  67d0659f-f771-4cd3-a209-4ccdf86b4a55    7,3G    60% /home
│                                                                                                  /
│         ntfs                                 7C4A28374A27ED18                                    
          ntfs                                 66D8F867D8F83741   

How did you go about setting up a dual boot system? What instructions did you follow?

Actually I had to skip bios settings, because once I heard that If I disable the CSM and enable Secure Boot, and If the graphic card is doesn’t support UEFI, the motherboard got soft brick in my motherboard. The graphic card is 1660S, so it must be has support, but I didn’t want to risk it. Will I have a problem If I do the bios settings?

If your windows OS is booting in UEFI mode, then you have to also install Linux in UEFI mode. Otherwise you can’t dual boot with grub2. You may be able to dual boot using the UEFI boot menu. If your graphics card works with Windows in UEFI mode, then there should be no reason it wouldn’t work for Linux.

Looking at the lsblk output it seems apparent that you installed fedora in MBR (legacy) boot mode and windows was installed in UEFI boot mode.
You must remove fedora and reinstall it in UEFI mode before you will be able to dual boot with windows. This is also noted above.

The simplest way would be to enter the bios setup and disable csm boot so the system would only boot in uefi mode before installing.