Window Key stopped being associated to the Application Launcher

Hello! I recently installed Fedora Jam 36 on my Lenovo IdeaPad Gaming 3 and after upgrading and finding some difficulties configuring the keyboard layout I noticed that the Windows Key stopped being associated to the Application Launcher but the system still recognizes it (I can change the position of the windows with it and already used xev).

I don’t know why is it like that in the moment, since what i did with the keyboard layout was changing the n/N key, so that when I press AltGr+n or AltGr+Shift+n I would get ñ/Ñ (I’m a Spanish native speaker on a German keyboard), which is what I used to do in Ubuntu, but in the process I noticed that I was also missing the accents (á/Á/é/É/í/Í/ó/Ó/ú/Ú) and it was not working what I was trying, so I looked for another approach and found out it is actually easy to change the language layouts. I added Spanish to the layouts and reverted the changes I made before.

I tried to follow the instructions on the second comment here: linux - How to associate the Fedora Start menu with the Windows keyboard? - Unix & Linux Stack Exchange
But I can’t find the “Xsession” file in the /etc/kde/kdm folder (Folder is empty) to run the file that links the Windows Key to F14 and add F14 as the shortcut for the App Launcher

This has happened to me in Fedora 37 Plasma. Not a fresh install but an upgrade from Fedora 36 Plasma.
Anyone know how to fix it?
I tried changing the Keyboard shortcut myself without success.