Wifi stops working followed by whole system freeze

Fedora 36 kde randomly freezes on my laptop. Basically, before the system freezes the wifi stops working and the wifi icons turns red. It shows the wifi is connected but internet doesn’t works and then I click on the icon to disconnect wifi but this causes the latte dock to freeze. After few seconds the whole system freezes. At that time if I open the system monitor its doesn’t show any stats, like no processing graph, no RAM graph or any network history. And if I try to reboot system it stucks at stopping two processes ( network manager.service and wpa_supplicant.sevice ) forever and sometimes it also shows a PCIe bus error. I will attach more screenshots later on for better understanding.

having the same issue here. first i loose the internet connection while wifi is still on (it may show limited connectivity or not), then i turn wifi off and when i click to reconnect it immediately completely frezes the system. it is extremely consistent - i got the exact same outcome 3 or 4 times in a row in 10 minutes.

fedora 36, kde and x11. no major updates or changes to the system prior to first occurance.


i turn wifi off and when i click to reconnect it immediately completely frezes the system

it only frezes the system if there’s active loss of the internet connectivity. so, let’s say, now it seems to work normally and i can disconnect and reconnect to my wifi without any issues.

actually, now i can add that the wifi fails in several minutes if there’s intensive download going on. and to get a freeze you just need to disconnect and wait, it just happens when wifi networks are rescanned.

upd: tried to cheese my way around it and reboot right after wifi dropped. it just froze on reboot cycle on black screen with fedora logo.

Things were same with me, I had to reinstall Fedora.

so i was doing some extensive testing and found out that this actually happens at any dl speed - unlimited at around 22mbps or limited at 15-10-5 and even at 2mbps, the key factor is just constant data transfer.

however, turns out this bs is somehow qbittorrent-specific. i tried ktorrent and it works. so?..