Wifi Stops working after downloading

I’m on Fedora workstation 37 running on HP Bs145Tu Laptop

Sometimes it’s so happens that when I am downloading any
large file my wifi stops internet but in the top panel it shows that it is connected to the wifi, no internet work . In order to solve it I have have to turn off wifi on wifi tile and then reconnect .

Hi - is that download always through your web browser, or sometimes through another program like Steam?

If you check your logs (I’ve historically just used the “Logs” application) right as that happens, do you see anything potentially related to the network, wireless, etc.?

this happend in two case

  1. i was downloading the gnome 44 beta iso via Motrix(download manager) flatpak of which extension works with Brave flatpak
  2. i was using SyncThingy to sync a backup of about 6gb between my smartphone and laptop

Have you checked for details using journalctl? Did wifi stop while a transfer was in progress or after the transfer completed? My (desktop) wifi has recently started disconnecting when inactive – I suspect some change in power management with recent updates. In journalctl I see:

CTRL-EVENT-DISCONNECTED bssid=X reason=4 locally_generated=1

802.11 reason codes gives “inactivity” for reason=4.

Wifi stop stopped while transferring was in progress, I guess it could be something power management in recent update

Hmm…while I haven’t had to do this on my current installation of Fedora, I had to follow the steps linked in this post on my previous ‘hop’ to Fedora, as well as on Linux Mint and Pop!_OS - perhaps it might be helpful here too?

(The post references latency, but for me the issue that this solved manifested as something similar to what you’re describing - long-duration activities being interrupted)


1 Like

before changing I tried to test at the current default settings and it was doing fine , successfully downloaded GNOME 44
beta build . Though I have applied above-mentioned just for good measure