Wifi stop working after sometime, but after restart comes back to work

I turn the laptop on, and after sometime wi-fi stops working and i have to restart the laptop to use it. It already happened during a work meeting, therefore i cannot use it to work.
When wifi stops working and i go to the Settings โ†’ wi-fi , there is a message: No Wi-fi Adapter found.

Thanks everybody, this is my first week using fedora :slight_smile:

1 Like

Welcome to the community @krionz

Nice that you use Fedora. Did you buy it with Fedora preinstalled? If not with what did you use it? Did you have same problems ?

Can you tell us more about your system?
Please execute the following command in a terminal and post the output here:
inxi -Fzx


Do you not have a internal network adapter (RJ45) where you could connect to the network with a cable?
It is faster and generally more stable. Just as workaround till you have the problem solved with the WiFi adapter.

1 Like

Yes, i had already forgotten about the cable. I will buy it.

Did you buy it with Fedora preinstalled? If not with what did you use it? Did you have same problems ?

I actually had the same problems with Ubuntu, but i also had problems with my mic on Ubuntu, and i had to change to Fedora to make it work ( after days lost trying to make google hangouts work with my mic ).

Please execute the following command in a terminal and post the output here:
inxi -Fzx
bash: inxi: command not foundโ€ฆ
Install package โ€˜inxiโ€™ to provide command โ€˜inxiโ€™? [N/y]

How should i install it?

1 Like

What happens if you type y when question appears?
sudo dnf install inxi in terminal will install it too.

1 Like

Sorry for the delay, here is the output of inxi -Fzx you asked:

    Kernel: 5.10.19-200.fc33.x86_64 x86_64 bits: 64 compiler: gcc 
    v: 2.35-18.fc33) Desktop: GNOME 3.38.3 
    Distro: Fedora release 33 (Thirty Three) 
    Type: Laptop System: LENOVO product: 80UH v: Lenovo ideapad 310-15ISK 
    serial: <filter> 
    Mobo: LENOVO model: Toronto 5A2 v: SDK0J40679 WIN serial: <filter> 
    UEFI: LENOVO v: 0XCN45WW date: 08/09/2018 
    ID-1: BAT0 charge: 13.8 Wh condition: 24.0/39.0 Wh (61%) 
    model: SMP L15M2PB5 status: Discharging 
    Info: Dual Core model: Intel Core i5-6200U bits: 64 type: MT MCP 
    arch: Skylake rev: 3 L2 cache: 3072 KiB 
    flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 
    bogomips: 19200 
Speed: 500 MHz min/max: 400/2800 MHz Core speeds (MHz): 1: 500 2: 500 
    3: 500 4: 500 
    Device-1: Intel Skylake GT2 [HD Graphics 520] vendor: Lenovo driver: i915 
        v: kernel bus ID: 00:02.0 
    Device-2: NVIDIA GK208BM [GeForce 920M] vendor: Lenovo driver: nouveau 
        v: kernel bus ID: 03:00.0 
    Device-3: Syntek EasyCamera type: USB driver: uvcvideo bus ID: 1-4:2 
Display: wayland server: Fedora Project X.org 1.20.10 
    compositor: gnome-shell driver: nouveau 
    note: display driver n/a - try sudo/root resolution: 1366x768~60Hz 
OpenGL: renderer: Mesa Intel HD Graphics 520 (SKL GT2) v: 4.6 Mesa 20.3.4 
    direct render: Yes 
    Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo 
        driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
    Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel v: kernel 
        bus ID: 03:00.1 
    Sound Server: ALSA v: k5.10.19-200.fc33.x86_64 
    Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
    vendor: Lenovo driver: r8169 v: kernel port: 4000 bus ID: 01:00.0 
    IF: enp1s0 state: down mac: <filter> 
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
    vendor: Lenovo driver: ath10k_pci v: kernel port: 4000 bus ID: 02:00.0 
    IF: wlp2s0 state: up mac: <filter> 
Device-3: Qualcomm Atheros type: USB driver: btusb bus ID: 1-7:4 
    IF-ID-1: virbr0 state: down mac: <filter> 
    IF-ID-2: virbr0-nic state: down mac: <filter> 
    Local Storage: total: 931.51 GiB used: 12.29 GiB (1.3%) 
    ID-1: /dev/sda vendor: Western Digital model: WD10JPCX-24UE4T0 
    size: 931.51 GiB 
    ID-1: / size: 312.21 GiB used: 12.27 GiB (3.9%) fs: ext4 dev: /dev/sda11 
    ID-1: swap-1 type: zram size: 3.84 GiB used: 0 KiB (0.0%) dev: /dev/zram0 
    System Temperatures: cpu: 39.0 C mobo: N/A gpu: nouveau temp: 36.0 C 
    Fan Speeds (RPM): N/A 
    Processes: 234 Uptime: 16m Memory: 7.67 GiB used: 1.75 GiB (22.8%) 
    Init: systemd runlevel: 5 Compilers: gcc: 10.2.1 Packages: 1679 
Shell: Bash v: 5.0.17 inxi: 3.1.08
1 Like

Try this one:

  1. sudo nano /etc/modprobe.d/ath10k_core.conf
  2. ADD >>> options ath10k_core skip_otp=y
  3. save file
  4. reboot

If not help, please delete added line from /etc/modprobe.d/ath10k_core.conf


If this hint was help u please select post as solution.

I have just added your line.
When i opened to add the line the file was empty.
The last time that the problem happened was when I spent a lot of time only reading PDFs and not using the internet. I just remembered that. I will do the same this weekend to see it the problem repeats.


The issue has not occurred again. I believe the problem is solved. Thank you.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.