Wifi router issues with Fedora installation (turned out to be a DDoS virus)

Max, thanks for finding and sharing the solution.

If you have some source(s), and especially if they provide some background, as to why you need to do specifically this, why it helps, etc. – it could be very useful to other people with the same – or similar but somewhat different – problem if you provide your sources here.

2 Likes

This is what I found, off another post on the internet:

modinfo iwlwifi
...
parm:           11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)

Info on 11n:

It is possible that the router either does not support this, or its firmware version includes a bug. This info can only be obtained from the router, though (or the maker). If other routers work without disabling 11n, then it’s a router issue rather than a Fedora one.

@FranciscoD Yes I don’t think it’s a Fedora issue, and not the Apple router issue either. It’s an excellent router, I’ve been using it for about 2 years now. And Fedora is a great OS too, I recently moved away from Ubuntu because it had issues, so I had to make this one work. It’s probably the way I have the home network setup. It’s a complex setup so there must’ve been a collision or incompatibility somewhere.

@nightromantic I really have no idea, I tried a lot of things until something worked.

1 Like

Ok, understood, then thanks again for sharing.

To all whom it may concern, I’ve updated my answer.

I thought the first solution regarding 11n_disable:disable fixed it, but it only seemed so. I’ve since been investigating. It turned out to be a known DoSS virus, infected the new Fedora installation via an open SSH port on the router.

Ugh, yikes!

Probably best to do a clean install!

If you want to diagnose the virus, please open a new topic.

1 Like

@maxfedora, please don’t tell me you have sshd running on port 22 on your Fedora machine with password authentication and root login permitted.

Yes! @maxfedora give us more information.

Trust me, after this bout I have no wish to diagnose anything! I am not doing a fresh install, it’s just an experimental server.

How come you didn’t figure it out if you’re such an expert? I don’t understand people who hang around forums and all they do is talk and criticize, but offer no resolve to any problem. They leave others figure out everything for themselves. You see such folks everywhere nowadays. It’s painful to watch.

Well, it could be useful for others to know what happens.
What known DoSS virus are you talking about? How did you discover that?

@maxfedora, I was not criticizing you in any way, please forgive me if you’ve felt like it.

Moreover, I still don’t think that what I’ve described is what you did )

Uh! Please.
Nobody here should be an expert that criticize other people! And people should not read posts in that way.

What I read is that @nightromantic was really surprised that SSH was exposed on the public Internet on port 22 with root access allowed. Because this is a basilar thing to avoid. I don’t read criticism or jeers coming from @nightromantic or anybody else.
All in all it was not clear in any previous post that the host was exposed on internet allowing ssh access on port 22.

If you do that and you look at the logs, you will see the logs flooded by attempts of access from all around the world :slight_smile: If you allow root access and your password is weak, it won’t take too long for some intrusion to happen.

I’m no expert, I have some experience – mainly with troubles I’ve encountered myself, some things I’ve read or talked with other people about – that’s all. Basically, I’m exactly the same user as you. I try to help, but I’m absolutely not the oracle or infallible know-it-all. I share what I know and what I think (and when I speculate I clearly say it) – and it helps some people.