WIFI Problem / Question Mark on the wifi icon

Hello, im a new user of Fedora, i installed it without any problems, but when i went back from a trip without connecting to internet it stopped working, it connects to the modem (router), but it doesnt connect to the internet, the wifi icon appears with a question mark, ive tried to get closer to the router (no luck), and tried to connect via cable to it (no luck too).

I checked if it was because the dns, proxy or vpn (i used the google dns but i dont have a proxy or vpn), but it doesnt appear to be the problem.

When i was on the trip i tried to connect a repeater, and obviously i connected to the webpage of it (, but i couldnt reach the page, so i did it on my phone, i tried to connect to a internet connection but it didnt worked too (too far away).

When i connect to the router via cable the wifi connection appeared fine, but i couldnt connect to the internet (nor lan or wireless), so i disconected it, but no luck.

When i go the browser and search something it appears as “could not find server ip address”

I did the things of the problem-fixer for the wireless red, and i restarted the router, but no luck

Please help, i dont want to reinstall fedora.

1 Like


Thanks, i tried to fix it, but no use, i did the dns provider and the DoT one, the first one changed the dns but didnt fix the issue, the second one send me messages about the directory or file missing, on resolve, and dnsovertls
And restart systemd-resolved.service failed with error code

1 Like


I dont know what that exactly means, but it doesnt look good, what next?

1 Like

Looks like your router has only IPv6 and no IPv4 connectivity.
Try rebooting it, or perform backup and factory reset.

On the other hand, some ISPs offer only IPv6 and provide NAT64+DNS64 for IPv4-only services:
IPv6 transition mechanism - Wikipedia

If this is your case, then specify some DNS64 and use it exclusively:
Public recursive name server - Wikipedia

My router has ipv4 and ipv6 (read it on the manual and web page of it), ill try to factory reset it, but i still think is problem of the laptop, ive been using this connection since i installed fedora, but since i tried to connect to the wifi (of the place where i went) and tried to connect a repeater the wireless connection (of the lap) has been acting a little weird

I tried to boot pop os from a flash drive, and connect to the internet with it, and no problem, so i think it is a problem with fedora, but i cant scratch my head on it

Maybe is a problem with the drivers?, i dont know

Ok, i just restarted my computer, i think it is easier, but i wonder what happened, good thing that i didnt have too much information

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.