Wifi on Thinkpad E14 Gen3: Install missing Firmware?

Sure

$ lspci -v
[...]
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 10)
        Subsystem: Lenovo Device 5097
        Flags: bus master, fast devsel, latency 0, IRQ 49, IOMMU group 9
        I/O ports at 3000 [size=256]
        Memory at fd504000 (64-bit, non-prefetchable) [size=4K]
        Memory at fd500000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: r8169
        Kernel modules: r8169

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. Device 8852
        Subsystem: Lenovo Device 4852
        Physical Slot: 0
        Flags: fast devsel, IRQ 255, IOMMU group 10
        I/O ports at 2000 [disabled] [size=256]
        Memory at fd400000 (64-bit, non-prefetchable) [disabled] [size=1M]
        Capabilities: <access denied>
        Kernel modules: rtw89pci
[...]

No kernel driver in use …

but it looks like make is skipping something because of vmlinux?

Yes, but I don’t know what.

are you sure that you have installed all the packages?

Yes, at least all you called. I even installed dpkg afterwards and tried again, to be sure. But no success so far.

ok,
it looks like the installation failed.
Since I used this repo they changed the code and removed some dependencies.
Maybe try the second latest commit: 6e82f69dc7c2f3b85aa0b7b6a37b76193cf1f6b4
from Jun 21, 2021.

hopefully that helps, otherwise you could open an Issue on Github.

That did not help either. Same missing “vmlinux”.

I will open a bug report.
Thanks again. :slight_smile:

I have created an Issue and will see if it helps: “unavailability of vmlinux” - missing dependency? · Issue #5 · lwfinger/rtw89 · GitHub

sorry, i am not an expert. :sweat_smile:
If it is a missing development tool, then maybe install all of them and not just a few with something like:

sudo dnf groupinstall “Development Tools” “Development Libraries”

greetings from germany.

1 Like

I will look into that, but I don’t want to “clutter” my fresh install too much, so I will read a bit in before.

No need to be sorry. You already (probably) set me on the right trackt. :smiley:

Do yourself a favor and get enough sleep, it is getting late here in germany. :sweat_smile:

1 Like

Sadly, nothing worked so far.
I have installed:

sudo dnf groupinstall “Development Tools” “Development Libraries”

But I get the same problem. :thinking:

So I got it working.
It is basically as @susi stated. Thanks again!
Here is how:

Install dependencies

sudo dnf install g++ gcc make automake gcc-c++ kernel-devel git

(I guess that are all)

Clone Git repository

git clone https://github.com/lwfinger/rtw89.git
cd rtw89

Compile and Install

make
sudo make install

Modprobe

The module should now be loaded automatically on boot, but you can test it manually with:

sudo modprobe rtw89pci

Note that this differs from the readme which, I guess, was just copy&pasted. (see bugreport)

If you get something like “Key was rejected by service”, then you have to deal with secure boot. (see below)

Disable Secure Boot or Sign Module

If you have secure boot enabled, then you have to sign the kernel module. The documentation explains how.

I just disabled secure boot in the BIOS settings. Maybe I sign the module later and readable secure boot. Or I wait until it is officially integrated and signed in Fedora and enable secure boot then again.

3 Likes

Sorry for cutting in, I have a problem with RTL8821CE in dual booting of Fedora 34 and Windows 10 Home.
Wi-Fi signal on Windows was strong and stable.
c19419b2cfa2f9790dad230967a107f87022bea2.png
On the other hand, Wi-Fi signal on Fedora 34 was unstable, it fluctuated all the time.
bb4366b05ba3079559383fe97828e0a2494fd367.png
Can reinstalling firmware solve such problem ?

I don’t know, but I guess that is possible.
But also: do you have only one access point?

I use tp-link TL-MR100 in my house. We have 2 notebooks, HP 14-ck0023TU dual booting Windows 10 Home and Fedora 34 Workstation Official Edition. Its Wi-Fi adapter is RTL8821CE. The Wi-Fi signal on notebook number 1 is strong in either Windows 10 Home or Fedora 34. On the other hand, the Wi-Fi signal on notebook number 2 is strong and stable in Windows 10 Home, but in Fedora 34 it is mostly weak and unstable and also fluctuated.

From your post, do I have to uninstall something first and do I have to replace rtw89 with rtw88 before the installation ?

This problem on notebook no. 2 came after I did some Windows Updates previously.

Sorry for asking in this question instead of starting a new topic and thank you so much in advance.

I can just tell from my experience: I did not uninstall any previous installed kernel module and I don’t think it would be necessary.

But after using wifi for two days, I can say that the signal-intensety is flickering.

6c6b188fbe5251c28216b7b816a0489f2920744c.png
beaeadb29e2d64b6ae63e0431205c4f6a7d346d4.png

But it is relative stable, so I hope it is just the indicator and not really weak.

I don’t know how it would be on windows, because I completly deleted it without testing.

The wifi is dependent upon several things for strength.
The band is first, and the 2.4 Ghz band is stronger and has a longer range than the 5 Ghz band.
Distance from the AP is a factor. The closer you are the stronger the signal.
Obstructions are a factor. Walls, furniture, appliances, etc. all can interfere with signal strength.
Other wifi APs in the area can interfere. Neighbors using the same wifi channel can be a significant interference and you might need to switch the machine to a different channel than the default to avoid interference. My neighbors only show me a 1 or 2 bar signal, but others have had a full strength signal from the neighbors on the same channel and had to switch channels to get a reliable connection.

All these are things to consider when trying to troubleshoot a bad wifi connection.

1 Like

Thank you that worked for me.

Upgraded:
elfutils-0.185-2.fc33.x86_64 elfutils-libelf-0.185-2.fc33.x86_64 elfutils-libs-0.185-2.fc33.x86_64
Installed:
autoconf-2.69-34.fc33.noarch automake-1.16.2-2.fc33.noarch bison-3.6.4-3.fc33.x86_64 elfutils-libelf-devel-0.185-2.fc33.x86_64
flex-2.6.4-5.fc33.x86_64 gcc-c+±10.3.1-1.fc33.x86_64 kernel-devel-5.12.12-200.fc33.x86_64 libstdc+±devel-10.3.1-1.fc33.x86_64
m4-1.4.18-15.fc33.x86_64 openssl-devel-1:1.1.1k-1.fc33.x86_64 zlib-devel-1.2.11-23.fc33.x86_64

Complete!

Even that I still have a missing repo etc/yum/

Warning: failed loading '/etc/yum.repos.d/fedora-33-unstable.repo', skipping.
Last metadata expiration check: 0:41:25 ago on Mon 28 Jun 2021 10:22:22 PM CEST.

There has been considerable discussion in the past on this forum about using fedora-33-unstable.repo

I suggest you search and read that discussion (more than one thread) about the problems and solution.

What about for Fedora Silverblue? Does anyone know?

Why don’t you provide a link to avoid confusion? When searching, all I see is a thread related to a VPN which installs a repo by that name

1 Like

I am not in front of my regular pc and with limited bandwidth have difficulties looking it up here, but IIRC it is installed when using the proton VPN service and several users had problems with the format of the .repo file as well as interference with updates otherwise, myself included.

Thanks and sorry I missed the context. @voodooviking here’s that thread https://discussion.fedoraproject.org/t/failed-to-load-etc-yum-repos-d-fedora-33-unstable-repo/75202/

1 Like

Just run sudo rpm-ostree usroverlay before the rest of the instructions. Only lasts until next reboot, but better than nothing

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.