WiFi Not Working After Building Driver On Kernel 6.7.4, Fedora 39

I built LWFinger’s driver (even though I have a kernel version above 6.6) because I had slow WiFi speeds.
I built the driver and read the part on HP and Lenovo laptops, and did the necessary steps.

I rebooted, but WiFi didn’t work. I tried unloading and reloading the module (rtw89_8852be), but it didn’t work. It kept saying the device was busy.
I deleted the file that I copied to /etc/modprobe.d .
Then I rebooted. I ran make uninstall and it said that it successfully uninstalled. I still have no WiFi however.

Now running “sudo modprobe -v rtw89-8852be” just makes it load forever, whereas earlier, it just said that the device was busy. Please help me in getting WiFi back.
OS- Fedora 39x86_64
Device: HP Pavilion Laptop 15-eh2xxx
Kernel Version- 6.7.4-200.fc39.x86_64

I think I have to use the in kernel drivers again. Any information on how to do that would be greatly appreciated
Also, WiFi still works on the previous kernel, 6.7.3-200.fc39.x86_64 (which i switched to using by the grub menu). Maybe it can be useful

I’m thinking that I should just use the old kernel until a new kernel update is available. Should the new kernel resolve the issue?

Make sure the LWFinger driver has been removed from wherever it ended up in /usr/lib/modules/6.7.4-200.fc39.x86_64/, then make sure you have the Fedora driver by checking the size and md5sum against the distro version:

% ls -l /usr/lib/modules/6.7.4-200.fc39.x86_64/kernel/drivers/net/wireless/realtek/rtw89/rtw89_8852be.ko.xz
-rw-r--r--. 1 root root 32012 Feb  4 20:00 /usr/lib/modules/6.7.4-200.fc39.x86_64/kernel/drivers/net/wireless/realtek/rtw89/rtw89_8852be.ko.xz
% md5sum /usr/lib/modules/6.7.4-200.fc39.x86_64/kernel/drivers/net/wireless/realtek/rtw89/rtw89_8852be.ko.xz
a68f82ceb99fba14c6b4b63b568e4275  /usr/lib/modules/6.7.4-200.fc39.x86_64/kernel/drivers/net/wireless/realtek/rtw89/rtw89_8852be.ko.xz

Sorry if this is a stupid question, but is /usr/lib/modules/6.7.4-200.fc39.x86_64/kernel/drivers/net/wireless/realtek/rtw89/rtw89_8852be.ko.xz supposed to exist whether i have the LWfinger driver installed or not?

I think that file comes with the kernel. Normally, if you install a patched module due to a problems with the kernel version, the patched version gets a different name and the broken model is blacklisted.

Kernel update fixed the issue