Wifi not connecting Fedora 35 with Intel Centrino Ultimate-N 6300

Hello Fedora community,

I have just started to Linux out of curiosity and I am a very inexperienced user. My first step was to install Debian with all its different desktop environments. I played around with those for some days and decided I liked Gnome the most. After learning more about Fedora’s Gnome experience and the ways updates are handled I replaced Debian.

Unfortunately there are some issues I can’t get fixed. Most importantly the (not connecting) wifi, which has worked perfectly on Debian - it just took the firmware from a USB stick while performing the network install and has worked flawlessly from there.

On Fedora things went a little different. While the network adaptor was recognized right away, it did not connect reliably after selecting the 5G network. It does not connect on startup, sometimes when I “forget” the network and reconnect it works (but like every fifth try).

I have tried the following steps:

update-crypto-policies --set DEFAULT:FEDORA32 - no effect

update-crypto-policies --set LEGACY - no effect



seemed to fix it for a brief moment, but the effect was gone after the next reboot.

Do you have any ideas what else I could do to fix the issue? I really like Fedora so far and would like to keep using it.

1 Like

If after using above configuration everything work fine, maybe you could start with adding it in a proper way inside /etc/NetworkManager/conf.d/mycustom.conf then systemctl restart NetworkManager.service.

Not sure it will solve your problem, but by putting the config inside /etc/NetworkManager/conf.d/ directory, it’s to make sure the config will overwrite everything related with NetworkManager.

Thank you for the support.
After making the changes and restarting the NetworkManager service wifi has connected right away.

After rebooting the issue is back though.

1 Like

Those mac address things make me remember some options on Gnome Settings > wifi. Click on gear icon of your current connection, then on tab identity we can fill everything there manually instead leave it blank. Not sure if it related.

This did not change anything unfortunately.

Is there any additional information I can provide to better identify the problem?

hi i had same issue.
try adding DNS info manually, this worked for me on Fedora 35.
link to post here.
or you can try adding DNS info graphically by Settings->Wi-Fi and click Gear Icon on your WiFi name → Ipv4 and disable automatic DNS option.
enter the manual DNS as suggested in above post.

Thank you, I tried the steps but it did not fix my issue. After the reboot it wifi will still not connect.

I have figured out how to get a connection eventually. That solution is not really practical, but might help to identify the issue:

  1. preferred network tries to connect
  2. connection fails
  3. I click another random network to connect from the list of available networks
  4. password prompt appears
  5. I cancel the dialogue
  6. now I click on the preferred network again from the list of available networks
  7. connection successful

Not a real solution to the problem though.

Maybe this adds some more context as well:

[fedora@fedora ~]$ dmesg | grep iwlwifi
[    5.920723] iwlwifi 0000:03:00.0: can't disable ASPM; OS doesn't have ASPM control
[    5.926484] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-6.ucode failed with error -2
[    5.926530] iwlwifi 0000:03:00.0: Direct firmware load for iwlwifi-6000-5.ucode failed with error -2
[    5.941164] iwlwifi 0000:03:00.0: loaded firmware version build 25532 6000-4.ucode op_mode iwldvm
[    6.113613] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUG enabled
[    6.113618] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[    6.113620] iwlwifi 0000:03:00.0: CONFIG_IWLWIFI_DEVICE_TRACING disabled
[    6.113622] iwlwifi 0000:03:00.0: Detected Intel(R) Centrino(R) Ultimate-N 6300 AGN, REV=0x74
[    6.750457] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0
[    8.046475] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1
[    8.288710] iwlwifi 0000:03:00.0: Radio type=0x0-0x3-0x1

Please read this.

My understanding there some hardware power saving that currently controlled by your laptop BIOS and kernel don’t have control on that. Maybe you could check your BIOS are there any hardware configuration that controlled by BIOS (power management?) and maybe you could try to disable it or if there any, set it something like leave to OS to control.

But I don’t know if it related with your problem.

Yeah, that one also caught my eye. I read it one and result was it’s safe to ignore.

I’m sure you have checked but under settings network details is the connect automatically and make available to other users checked.

Yeah, I did not touch those, but they are both active.

A year ago I investigated wireless connection problems with “Intel Centrino Ultimate-N 6300”. Reproducable problem with Microsoft Windows (7 and 10) and GNU/Linux (Fedora 32) with wireless network operating in mixed mode (N and some other, cannot remember). Sometimes connection worked, sometimes not. When connected transfer speed was bad.
As far as I remember Intel acknowledged the problem several years ago in an errata and said it will not fix the driver, because that card is out of support. Solution for me: switch to “Intel WiFi Link 5100” WLAN card.

1 Like