Wifi Networking Issue with F37 Beta Server

I’m guessing that few test Fedora Server using a wifi network connection, so this issue may be unnoticed. I tested the Fedora 37 Beta Server Standard ISO image install on the following hardware:

  • TOSHIBA product: Satellite C650 v: PSC2EU-001027
  • Mobo: TOSHIBA model: Portable PC serial: BIOS: INSYDE v: 1.00 date: 04/01/2011
  • CPU: Topology: Dual Core model: Intel Core i3-2310M bits: 64 type: MT MCP arch: Sandy Bridge
  • Graphics: Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Toshiba America Info Systems driver: i915
  • Network: Device-1: Qualcomm Atheros AR8152 v2.0 Fast Ethernet vendor: Toshiba America Info Systems driver: atl1c; Device-2: Realtek RTL8188CE 802.11b/g/n WiFi Adapter driver: rtl8192ce

I was doing the install mostly to review our current documentation for Fedora Server getting ready for the F37 release. The old laptop had a wifi adapter, so I decided to set up networking during the install using the wifi adapter instead of the Ethernet port. After installation the following strange networking behaviors showed up.

  • The system had received an internal IP address from my DHCP server. My DHCP server could see the system connected to the network at the address it was assigned. The Fedora Server login prompt correctly displayed the internal IP address that it had been given.
  • Yet, I could not ssh to the system. Cockpit would not come up when I tried to access Cockpit from my workstation on the same LAN. I was also unable to ping the system from my workstation on the same LAN.
  • However, when I logged into the system directly, I had the correct IP address connected through the wireless adapter, and I could do a “sudo dnf update” without any problems.

I tried plugging in an Ethernet cable, which still didn’t allow me to connect remotely to the system, until I rebooted. After a reboot, I was able to ssh, connect to Cockpit, and ping the system. However, when I closed the lid of the laptop (putting the system to sleep) and then opened the lid again later, once again coming out of sleep I have all of the same connection issues that I had before. I’m not sure what is happening during sleep that causes the remote connections to be lost. When I run “ip address” it looks the same when I reboot and have the Ethernet cable plugged in as when I wake the system from sleep and run the command again.

Is it possible that I have run into a bug in the way the firewall is setup or some other networking stack default that would block remote connections over wifi on Fedora Server 37 Beta?