WiFI - losing connection and a missing network (Lenovo Legion 5 2021)


I’m using a Lenovo Legion 5 (2021 model). It has RTL8852AE wifi.
I’m using the rtw89 driver.

I’m having two problems:

  1. We have two access points in the apartment. One of them, which is of a router that’s right on my desk, does not appear in the list of available networks. It worked up until half an hour ago, and then it disappeared. I should mention that I no problems connecting to this access point via other devices or even Windows on the same laptop.

  2. If I’m connected to the other access point, I’m getting a pathetic internet speed of around 2 Mb/s (200 Mb/s with the access point near me)

  3. The connection is unstable. While it remains connected to the WiFi network, it loses internet access and resolves when I rejoin the network.

I’d appreciate suggestions. Thanks.

Greetings From Another Lenovo Legion(2020) 5 user

I have had no issues with my laptop and there might be some ways to solve your problem
In the past months I had similar kind of issues with my Bluetooth but that was quickly resolved with new kernel version… It is running now flawlessly

Can you tell me what spin are you using (GNOME/KDE) ?
Because some KDE user have reported some similar issues

And solution to this issue can be
You first need to downgrade the wifi drivers
And see how it runs
Then upgrade back to the latest wifi drivers that fits your wifi module…

Hope that it works!!


Does your Legion 5 have the same wifi module as mine?
I’m running Fedora 34 which I believe has GNOME 40.

Older versions of the wifi driver are not available to download.
I did reinstall the driver, but that didn’t help.

Maybe this thread will help

My kernel is already updated and the wifi driver installed (and sort of working).
The issue is with how unstable and slow it is…

I appreciate the help, though it seems that there’s no proper wifi support for my laptop as of now.

FYI, there are sometimes small tweaks in a driver that work better on newer versions of the card. To find out for sure what chipset is in your card simply run “inxi -Nxx” and look for the chip-ID: related to that device. (you may need to install inxi) Then search for a driver for that chip-ID.
The part of interest will look something like chip-ID: 168c:0030

Sometimes the proper driver may be different than what is found for the device ID since even with the same device name they may use a different chipset with upgrades.

Yes it does !!

@yonyz didn’t this method worked for you?
It should have