WiFi keeps disconnecting and asking for password

It’s happening on my work’s PC and it’s making me mad. Just wanted to start from zero this new year with Linux.

WiFi runs good for X time; may be 5 minutes or 10 hours. But at a point, it disconnects and I have to restart NetworkManager until it works again (sometimes one time, sometimes 50).

I have a TP-Link TL wn722n v1

Here goes the dmesg information when I can’t connect:

[ 3052.682234] wlp0s2f1u3: disassociated from 08:4f:0a:4b:cd:4c (Reason: 2=PREV_AUTH_NOT_VALID)
[ 3055.251532] wlp0s2f1u3: authenticate with 08:4f:0a:4b:cd:4c
[ 3055.251560] wlp0s2f1u3: 80 MHz not supported, disabling VHT
[ 3055.380416] wlp0s2f1u3: send auth to 08:4f:0a:4b:cd:4c (try 1/3)
[ 3055.383389] wlp0s2f1u3: authenticated
[ 3055.385228] wlp0s2f1u3: associate with 08:4f:0a:4b:cd:4c (try 1/3)
[ 3055.391383] wlp0s2f1u3: RX AssocResp from 08:4f:0a:4b:cd:4c (capab=0x1431 status=0 aid=1)
[ 3055.398247] wlp0s2f1u3: associated
[ 3055.398367] wlp0s2f1u3: Limiting TX power to 30 (30 - 0) dBm as advertised by 08:4f:0a:4b:cd:4c
[ 3059.511610] wlp0s2f1u3: disassociated from 08:4f:0a:4b:cd:4c (Reason: 2=PREV_AUTH_NOT_VALID)
[ 3059.782424] wlp0s2f1u3: authenticate with 08:4f:0a:4b:cd:4c
[ 3059.782449] wlp0s2f1u3: 80 MHz not supported, disabling VHT
[ 3059.911801] wlp0s2f1u3: send auth to 08:4f:0a:4b:cd:4c (try 1/3)
[ 3059.914739] wlp0s2f1u3: authenticated
[ 3059.915667] wlp0s2f1u3: associate with 08:4f:0a:4b:cd:4c (try 1/3)
[ 3059.921250] wlp0s2f1u3: RX AssocResp from 08:4f:0a:4b:cd:4c (capab=0x1431 status=0 aid=1)
[ 3059.927504] wlp0s2f1u3: associated
[ 3060.001159] wlp0s2f1u3: Limiting TX power to 30 (30 - 0) dBm as advertised by 08:4f:0a:4b:cd:4c
[ 3064.044143] wlp0s2f1u3: disassociated from 08:4f:0a:4b:cd:4c (Reason: 2=PREV_AUTH_NOT_VALID)
[ 3066.363036] wlp0s2f1u3: authenticate with 08:4f:0a:4b:cd:4c
[ 3066.363083] wlp0s2f1u3: 80 MHz not supported, disabling VHT
[ 3066.492921] wlp0s2f1u3: send auth to 08:4f:0a:4b:cd:4c (try 1/3)
[ 3066.495447] wlp0s2f1u3: authenticated
[ 3066.496732] wlp0s2f1u3: associate with 08:4f:0a:4b:cd:4c (try 1/3)
[ 3066.505890] wlp0s2f1u3: RX AssocResp from 08:4f:0a:4b:cd:4c (capab=0x1431 status=0 aid=1)
[ 3066.511998] wlp0s2f1u3: associated
[ 3066.554904] wlp0s2f1u3: Limiting TX power to 30 (30 - 0) dBm as advertised by 08:4f:0a:4b:cd:4c
[ 3070.621502] wlp0s2f1u3: disassociated from 08:4f:0a:4b:cd:4c (Reason: 2=PREV_AUTH_NOT_VALID)
[ 3072.710773] wlp0s2f1u3: authenticate with 08:4f:0a:4b:cd:4c
[ 3072.710822] wlp0s2f1u3: 80 MHz not supported, disabling VHT
[ 3072.846055] wlp0s2f1u3: send auth to 08:4f:0a:4b:cd:4c (try 1/3)
[ 3072.850733] wlp0s2f1u3: authenticated
[ 3072.851837] wlp0s2f1u3: associate with 08:4f:0a:4b:cd:4c (try 1/3)
[ 3072.860616] wlp0s2f1u3: RX AssocResp from 08:4f:0a:4b:cd:4c (capab=0x1431 status=0 aid=1)
[ 3072.866786] wlp0s2f1u3: associated
[ 3072.904667] wlp0s2f1u3: Limiting TX power to 30 (30 - 0) dBm as advertised by 08:4f:0a:4b:cd:4c
[ 3076.981498] wlp0s2f1u3: disassociated from 08:4f:0a:4b:cd:4c (Reason: 2=PREV_AUTH_NOT_VALID)
[ 3078.834040] wlp0s2f1u3: authenticate with 08:4f:0a:4b:cd:4c
[ 3078.834087] wlp0s2f1u3: 80 MHz not supported, disabling VHT
[ 3078.963799] wlp0s2f1u3: send auth to 08:4f:0a:4b:cd:4c (try 1/3)
[ 3078.966331] wlp0s2f1u3: authenticated
[ 3078.969241] wlp0s2f1u3: associate with 08:4f:0a:4b:cd:4c (try 1/3)
[ 3078.974849] wlp0s2f1u3: RX AssocResp from 08:4f:0a:4b:cd:4c (capab=0x1431 status=0 aid=1)
[ 3078.981019] wlp0s2f1u3: associated
[ 3079.047912] wlp0s2f1u3: Limiting TX power to 30 (30 - 0) dBm as advertised by 08:4f:0a:4b:cd:4c
[ 3083.101447] wlp0s2f1u3: disassociated from 08:4f:0a:4b:cd:4c (Reason: 2=PREV_AUTH_NOT_VALID)

… and it keeps going and going. This time, I disconected and reconnected the WiFi adapter and it worked properly on the first try. dmesg said:

usb 2-3: USB disconnect, device number 6
[ 3104.603330] ath: phy1: Failed to wakeup in 500us
[ 3104.613501] ath: phy1: Failed to wakeup in 500us
[ 3104.625429] usb 2-3: ath9k_htc: USB layer deinitialized
[ 3105.038275] usb 2-3: new high-speed USB device number 7 using ehci-pci
[ 3108.388314] usb 2-3: new high-speed USB device number 8 using ehci-pci
[ 3108.537180] usb 2-3: New USB device found, idVendor=0cf3, idProduct=9271, bcdDevice= 1.08
[ 3108.537200] usb 2-3: New USB device strings: Mfr=16, Product=32, SerialNumber=48
[ 3108.537208] usb 2-3: Product: USB2.0 WLAN
[ 3108.537244] usb 2-3: Manufacturer: ATHEROS
[ 3108.537250] usb 2-3: SerialNumber: 12345
[ 3108.538030] usb 2-3: ath9k_htc: Firmware ath9k_htc/htc_9271-1.4.0.fw requested
[ 3108.835993] usb 2-3: ath9k_htc: Transferred FW: ath9k_htc/htc_9271-1.4.0.fw, size: 51008
[ 3109.086934] ath9k_htc 2-3:1.0: ath9k_htc: HTC initialized with 33 credits
[ 3109.317934] ath9k_htc 2-3:1.0: ath9k_htc: FW Version: 1.4
[ 3109.317950] ath9k_htc 2-3:1.0: FW RMW support: On
[ 3109.317956] ath: EEPROM regdomain: 0x809c
[ 3109.317961] ath: EEPROM indicates we should expect a country code
[ 3109.317964] ath: doing EEPROM country->regdmn map search
[ 3109.317967] ath: country maps to regdmn code: 0x52
[ 3109.317971] ath: Country alpha2 being used: CN
[ 3109.317975] ath: Regpair used: 0x52
[ 3109.325025] ieee80211 phy2: Atheros AR9271 Rev:1
[ 3109.347720] ath9k_htc 2-3:1.0 wlp0s2f1u3: renamed from wlan0
[ 3121.003081] wlp0s2f1u3: authenticate with 08:4f:0a:4b:cd:4c
[ 3121.003128] wlp0s2f1u3: 80 MHz not supported, disabling VHT
[ 3121.131517] wlp0s2f1u3: send auth to 08:4f:0a:4b:cd:4c (try 1/3)
[ 3121.136660] wlp0s2f1u3: authenticated
[ 3121.138327] wlp0s2f1u3: associate with 08:4f:0a:4b:cd:4c (try 1/3)
[ 3121.149173] wlp0s2f1u3: RX AssocResp from 08:4f:0a:4b:cd:4c (capab=0x1431 status=0 aid=1)
[ 3121.155326] wlp0s2f1u3: associated
[ 3121.237579] wlp0s2f1u3: Limiting TX power to 30 (30 - 0) dBm as advertised by 08:4f:0a:4b:cd:4c

I’m waiting for it to fail again. If anyone can give me a hand I’ll be grateful! Thank you all.

Hi! Can you clarify the title of this question? It’s rather confusing!

1 Like

I’d just like to applaud your response here - most other places on the interweb would have been derisive. I’ve seen worse for less.

I think I need to hang out in more wholesome communities… :smiley:

1 Like

A quick google search suggests that buggy firmware can cause that error. Have you tried updating the firmware? (Running fwupdmgr get-updates while your device is connected might show if an update is available. If that doesn’t work, the next place to check would be the manufacturer’s website.)

Does this happen with a 6.6.x kernel or only 6.7.x? I’ve been having the same problem with 6.7.x kernels.

ath9k USB issues should be considered to rule out known causes.

It might help identify a pattern if you provide a journalctl fragment corresponding to the original post.

nazareno@fedora:~$  journalctl
Jan 29 15:00:05 fedora kernel: Linux version 6.5.6-300.fc39.x86_64 (mockbuild@f>
Jan 29 15:00:05 fedora kernel: Command line: BOOT_IMAGE=(hd0,msdos3)/vmlinuz-6.>
Jan 29 15:00:05 fedora kernel: BIOS-provided physical RAM map:
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x0000000000000000-0x00000000000>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x000000000009b400-0x00000000000>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x00000000000e2000-0x00000000000>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x0000000000100000-0x00000000bff>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x00000000bffa0000-0x00000000bff>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x00000000bffb8000-0x00000000bff>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x00000000bffe0000-0x00000000bff>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x00000000bfff0000-0x00000000bff>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x00000000fec00000-0x00000000fec>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x00000000fee00000-0x00000000fee>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x00000000fff00000-0x00000000fff>
Jan 29 15:00:05 fedora kernel: BIOS-e820: [mem 0x0000000100000000-0x000000023ff>
Jan 29 15:00:05 fedora kernel: NX (Execute Disable) protection: active
Jan 29 15:00:05 fedora kernel: SMBIOS 2.5 present.
Jan 29 15:00:05 fedora kernel: DMI: System manufacturer System Product Name/M4N>
Jan 29 15:00:05 fedora kernel: tsc: Fast TSC calibration using PIT
Jan 29 15:00:05 fedora kernel: tsc: Detected 2913.249 MHz processor
Jan 29 15:00:05 fedora kernel: e820: update [mem 0x00000000-0x00000fff] usable >
Jan 29 15:00:05 fedora kernel: e820: remove [mem 0x000a0000-0x000fffff] usable
Jan 29 15:00:05 fedora kernel: last_pfn = 0x240000 max_arch_pfn = 0x400000000

journalctl says Linux version 6.5.6-300.fc39.x86_64
cat /proc/version says Linux version 6.6.13-200.fc39.x86_64
:thinking: :thinking: :thinking:

Did you fixed it? How?

I get:
WARNING: UEFI firmware can not be updated in legacy BIOS mode

There is a solution for it but I will need to reinstall all OS installed in my system. Can’t do it right now

Feb 08 12:49:43 kernel: wlo1: deauthenticating from 4c:38:d8:00:e4:37 by local choice (Reason: 2=PREV_AUTH_NOT_VALID)
Feb 08 12:49:46 kernel: ath10k_pci 0000:03:00.0: failed to install key for vdev 0 peer 4c:38:d8:00:e4:37: -110
Feb 08 12:49:46 kernel: wlo1: failed to remove key (0, 4c:38:d8:00:e4:37) from hardware (-110)
Feb 08 12:49:46 kernel: wlo1: authenticate with 4c:38:d8:00:e4:37 (local address=80:30:49:ac:f8:bd)
Feb 08 12:49:46 kernel: wlo1: send auth to 4c:38:d8:00:e4:37 (try 1/3)
Feb 08 12:49:46 kernel: wlo1: send auth to 4c:38:d8:00:e4:37 (try 2/3)
Feb 08 12:49:46 kernel: wlo1: authenticated
Feb 08 12:49:46 kernel: wlo1: associate with 4c:38:d8:00:e4:37 (try 1/3)
Feb 08 12:49:46 kernel: wlo1: RX AssocResp from 4c:38:d8:00:e4:37 (capab=0x1511 status=0 aid=7)
Feb 08 12:49:46 kernel: wlo1: associated
Feb 08 12:49:46 kernel: ath: EEPROM regdomain: 0x833a
Feb 08 12:49:46 kernel: ath: EEPROM indicates we should expect a country code
Feb 08 12:49:46 kernel: ath: doing EEPROM country->regdmn map search
Feb 08 12:49:46 kernel: ath: country maps to regdmn code: 0x37
Feb 08 12:49:46 kernel: ath: Country alpha2 being used: GB
Feb 08 12:49:46 kernel: ath: Regpair used: 0x37
Feb 08 12:49:46 kernel: ath: regdomain 0x833a dynamically updated by country element
Feb 08 12:49:46 kernel: wlo1: Limiting TX power to 23 (23 - 0) dBm as advertised by 4c:38:d8:00:e4:37
Feb 08 12:50:23 kernel: wlo1: AP is in CSA process, reject auth
Feb 08 12:50:30 kernel: wlo1: deauthenticating from 4c:38:d8:00:e4:37 by local choice (Reason: 2=PREV_AUTH_NOT_VALID)
Feb 08 12:50:30 kernel: wlo1: authenticate with 4c:38:d8:00:e4:37 (local address=80:30:49:ac:f8:bd)
Feb 08 12:50:30 kernel: wlo1: send auth to 4c:38:d8:00:e4:37 (try 1/3)
Feb 08 12:50:30 kernel: wlo1: send auth to 4c:38:d8:00:e4:37 (try 2/3)
Feb 08 12:50:30 kernel: wlo1: authenticated
Feb 08 12:50:30 kernel: wlo1: associate with 4c:38:d8:00:e4:37 (try 1/3)
Feb 08 12:50:30 kernel: wlo1: RX AssocResp from 4c:38:d8:00:e4:37 (capab=0x1511 status=0 aid=7)
Feb 08 12:50:30 kernel: wlo1: associated
Feb 08 12:50:30 kernel: ath: EEPROM regdomain: 0x833a
Feb 08 12:50:30 kernel: ath: EEPROM indicates we should expect a country code
Feb 08 12:50:30 kernel: ath: doing EEPROM country->regdmn map search
Feb 08 12:50:30 kernel: ath: country maps to regdmn code: 0x37
Feb 08 12:50:30 kernel: ath: Country alpha2 being used: GB
Feb 08 12:50:30 kernel: ath: Regpair used: 0x37
Feb 08 12:50:30 kernel: ath: regdomain 0x833a dynamically updated by country element
Feb 08 12:50:30 kernel: wlo1: deauthenticating from 4c:38:d8:00:e4:37 by local choice (Reason: 1=UNSPECIFIED)
Feb 08 12:50:30 kernel: ath: country maps to regdmn code: 0x37
Feb 08 12:50:30 kernel: wlo1: send auth to 4c:38:d8:00:e4:37 (try 1/3)
Feb 08 12:50:30 kernel: wlo1: send auth to 4c:38:d8:00:e4:37 (try 2/3)
Feb 08 12:50:30 kernel: wlo1: authenticated
Feb 08 12:50:30 kernel: wlo1: associate with 4c:38:d8:00:e4:37 (try 1/3)
Feb 08 12:50:30 kernel: wlo1: RX AssocResp from 4c:38:d8:00:e4:37 (capab=0x1511 status=0 aid=7)
Feb 08 12:50:30 kernel: wlo1: associated
Feb 08 12:50:30 kernel: ath: EEPROM regdomain: 0x833a
Feb 08 12:50:30 kernel: ath: EEPROM indicates we should expect a country code
Feb 08 12:50:30 kernel: ath: doing EEPROM country->regdmn map search
Feb 08 12:50:30 kernel: ath: country maps to regdmn code: 0x37
Feb 08 12:50:30 kernel: ath: Country alpha2 being used: GB
Feb 08 12:50:30 kernel: ath: Regpair used: 0x37
Feb 08 12:50:30 kernel: ath: regdomain 0x833a dynamically updated by country element
Feb 08 12:50:30 kernel: wlo1: deauthenticating from 4c:38:d8:00:e4:37 by local choice (Reason: 1=UNSPECIFIED)

Interestingly this only happens when connecting to an extender’s 5 GHz channel, not 2.4 GHz. Both work with the router.

EDIT: Sorry, this seems to be unrelated. Apologies.

The older kernel version was either an old boot or a recent boot with the older kernel selected. You can list the available boot numbers and times with journalctl --list-boots, then use the -b N option to select a specific boot. It is helpful to note the date and time when a problem occurs.