Wifi Driver Issue

Still at unavailable I’m afraid :confused:

When you do nmcli radio wifi on, what does happen? I assume an error output? What error?

When you execute nmcli radio wifi on, also check the output of sudo journalctl --since "2 minute ago" within a minute after you entered the nmcli radio wifi on command, and let us know the output. Please use the ` for that!

I just saw “Realtek RTL8111/8168/8411” is a wired device, I assumed you have none (my bad). Of course it will be not turned on with radio command. So nmcli seems to not see the wifi device at all.

Anyway, let us know the output as requested. But I think the issue is a layer below, driver. Let’s see what the error output / journalctl says.

If the output does not suggest something else, my expectation is that you would need to install a patch yourself, although I remain wondering why this device is not supported by default. Maybe I will have time next week to check this out (cannot guarantee yet). I will be off for now, but if you want to get deeper into it / try it, search for Realtek “8811CU” fedora or something like that.

Related pages are:
1957828 – Add Realtek 8821 Drivers to Fedora/Silverblue ISO
GitHub - brektrou/rtl8821CU: Realtek RTL8811CU/RTL8821CU USB Wi-Fi adapter driver for Linux

Be aware that external patches are not supported/tested by Fedora and you do it at your own risk ! Finally, installing external patches always implies you trust the author. Also, it implies that you take yourself the responsibility to update them. Just to be sure that you generally know about that.

Also, maybe someone else in ask.:fedora: has experience with alternatives to make this wifi device work?

I just put the question about the RTL8811 in the mailing list, maybe there are already some approaches for that. I’ll let you know. Or maybe I missed something, had a long day :wink:

One problem may be if you have secure boot enabled. Try turning that off in BIOS. Also, you may want to peruse the output of dmesg just after connecting that device and see what messages may be shown about it.

Finally, the same with journalctl -S -2minutes to see what info is available.

You have been given lots of good advice, and mine is that in the event turning off secure boot and rebooting does not work then you should install the drivers yourself.

A quick search for driver for 0bda:c811 rtl8811cu on fedora shows this as the first result, and the instructions are there for how to do the install.

It has been asked repeatedly that you post data within the Preformatted text tags available with the </> button on the tool bar above when you are writing a post.

1 Like

Mentioned already above :wink: Yet, it is a way I suggest to avoid if possible… But as I said, if journalctl does not suggest anything else, it seems to be the only one … :frowning: Nevertheless, I think we should wait for journalctl.

Good idea!

Sounds interesting. Do we have precedents where secure boot was related to such cases?

If journalctl / dmesg / secure boot do not lead to a solution:

Someone could build a kernel module of it in copr. It seems eligible.

@danocar as far as I understood it, you are computer science student? Maybe that would be an interesting challenge for you? And you would obviously profit from it yourself in two ways.


An example from the mailing list:
Overview - rtl8821ce-kmod - Pagure.io → which is from https://github.com/sergiomb2/rtl8821ce/tree/master/contrib (which is forked from GitHub - tomaspinho/rtl8821ce ) → which ends up at sergiomb/akmod-rtl8821ce Copr

Alternatively, build a kernel module for rpmfusion, although I think copr makes more sense.

In both ways, you can get it into the management of dnf.

Just an idea that might create knowledge and is funny :wink: If you are interested in that, you should start by enlisting in the developer mailing list, where you will find many people who are more experienced in packaging than me :smiley: