WiFi broke after update (iMac 7,1 - Broadcom BCM4321 rev 03 - Fedora 35)

Hello there

Earlier this afternoon I updated my iMac. Looks like there was a kernel update on Fedora 35 (from 5.16 to 5.17), so I upgraded without any other consideration. After a reboot, wifi was simply broken, and you know it is quite complicated to put it to work from the ground up, so I tried to do it all over again, nothing worked.

So, using lspci -k:

04:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4321 802.11a/b/g/n (rev 03)
Subsystem: Apple Inc. AirPort Extreme
Kernel modules: ssb

Then, sudo dnf info broadcom-wl

Paquetes disponibles
Nombre : broadcom-wl
Versión :
Lanzamiento : 17.fc35
Arquitectura : noarch
Tamaño : 24 k
Fuente : broadcom-wl-
Repositorio : rpmfusion-nonfree
Resumen : Common files for Broadcom 802.11 STA driver
URL : Support Documents and Downloads
Licencia : Redistributable, no modification permitted
Descripción : This package contains the license, README.txt and configuration
: files for the Broadcom 802.11 Linux STA Driver for WiFi, a Linux
: device driver for use with Broadcom’s BCM4311-, BCM4312-, BCM4313-,
: BCM4321-, BCM4322-, BCM43142-, BCM43224-, BCM43225-, BCM43227-,
: BCM43228-, BCM4331-, BCM4360 and -BCM4352- based hardware.

Finally, the curious thing came after iwconfig:

lo no wireless extensions.

ens5 no wireless extensions.

I use my iMac away from the router and any other wired connection, so puting the Wifi (and bluetooth) to work is quite important.

Any ideas?

Thanks in advance


1 Like

I guess the simplest thing to do to get it working is to boot into an older kernel. It could be a kernel issue, or one with the broadcom drivers—not easy to tell at the moment. Anything else in the logs?

To be honest, I wouldn’t know what to look for there.

I’m using GNOME Logs to sort things out. But I can’t understand most of it. I’m seeing some error messages but I don’t know how related they are to the issue at hand. For example:

GLib-GIO-CRITICAL: g_bus_get_sync: assertion ‘error == NULL || *error == NULL’ failed


I/O error, dev sr0, sector 7368704 op 0x0:(READ) flags 0x80700 phys_seg 27 prio class 0

I have not a clue, sorry.