Wifi and Airplane mode keep turning on when rebooting

Wifi and Airplane mode keep turning on when rebooting on Fedora 34.
Is their a way to stop this happening? Thanks.
Here is the system info:

  Kernel: 5.12.15-300.fc34.x86_64 x86_64 bits: 64 compiler: gcc 
  v: 2.35.1-41.fc34 
  parameters: BOOT_IMAGE=(hd0,msdos1)/vmlinuz-5.12.15-300.fc34.x86_64 
  root=UUID=437a8883-c095-4111-95b9-9c8bbd0d99ff ro rootflags=subvol=root 
  rhgb quiet 
  Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.0 
  Distro: Fedora release 34 (Thirty Four) 
  Type: Laptop System: TOSHIBA product: Satellite C850 v: PSKCCA-02D00M 
  serial: <filter> 
  Mobo: Type2 - Board Vendor Name1 model: Type2 - Board Product Name1 
  v: Type2 - Board Version serial: <filter> UEFI-[Legacy]: Insyde v: 6.60 
  date: 4/03/2013 
  ID-1: BAT0 charge: 36.0 Wh (100.0%) condition: 36.0/48.4 Wh (74.5%) 
  volts: 12.4 min: 10.8 model: TKBSS NS2P3SZMC4WR type: Li-ion serial: N/A 
  status: Full 
  Info: Dual Core model: Intel Core i5-2450M bits: 64 type: MT MCP 
  arch: Sandy Bridge family: 6 model-id: 2A (42) stepping: 7 microcode: 2F 
  cache: L2: 3 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19955 
  Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Whistler LE [Radeon HD 6610M/7610M] vendor: Toshiba 
  driver: radeon v: kernel bus-ID: 01:00.0 chip-ID: 1002:6742 class-ID: 0300 
  Display: wayland server: X.Org compositor: gnome-shell driver: 
  loaded: radeon note: n/a (using device driver) - try sudo/root 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: XWAYLAND0 res: 1366x768 hz: 60 
  renderer: AMD TURKS (DRM 2.50.0 / 5.12.15-300.fc34.x86_64 LLVM 12.0.0) 
  v: 3.3 Mesa 21.1.5 compat-v: 3.1 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Toshiba 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 
  class-ID: 0403 
  Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] 
  vendor: Toshiba driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
  chip-ID: 1002:aa90 class-ID: 0403 
  Sound Server-1: ALSA v: k5.12.15-300.fc34.x86_64 running: yes 
  Sound Server-2: PulseAudio v: 14.2-rebootstrapped running: no 
  Sound Server-3: PipeWire v: 0.3.31 running: yes 
  Device-1: Realtek RTL8723AE PCIe Wireless Network Adapter 
  driver: rtl8723ae v: kernel port: 3000 bus-ID: 08:00.0 chip-ID: 10ec:8723 
  class-ID: 0280 
  IF: wlp8s0 state: down mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Toshiba 
  driver: r8169 v: kernel port: 2000 bus-ID: 09:00.0 chip-ID: 10ec:8136 
  class-ID: 0200 
  IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IF-ID-1: virbr0 state: down mac: <filter> 
  Local Storage: total: 465.76 GiB used: 123.39 GiB (26.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Toshiba model: MQ01ABD050 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B 
  speed: 3.0 Gb/s rotation: 5400 rpm serial: <filter> rev: 2M scheme: MBR 
  ID-1: / raw-size: 464.76 GiB size: 464.76 GiB (100.00%) 
  used: 123.13 GiB (26.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot raw-size: 1024 MiB size: 975.9 MiB (95.30%) 
  used: 268.3 MiB (27.5%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 
  ID-3: /home raw-size: 464.76 GiB size: 464.76 GiB (100.00%) 
  used: 123.13 GiB (26.5%) fs: btrfs dev: /dev/sda2 maj-min: 8:2 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: zram size: 7.72 GiB used: 0 KiB (0.0%) priority: 100 
  dev: /dev/zram0 
  System Temperatures: cpu: 51.0 C mobo: N/A gpu: radeon temp: 46.5 C 
  Fan Speeds (RPM): N/A 
  Processes: 327 Uptime: 15m wakeups: 2 Memory: 7.72 GiB 
  used: 1.69 GiB (21.9%) Init: systemd v: 248 runlevel: 5 
  target: graphical.target tool: systemctl Compilers: gcc: 11.1.1 Packages: 
  rpm: 1982 lib: 463 flatpak: 0 Shell: Bash v: 5.1.0 
  running-in: gnome-terminal inxi: 3.3.03 
[paul@localhost ~]$ 

Turn airplane mode off and wifi on. Then do a clean shutdown and reboot. The config should remain.

You do need to go into network settings and make certain the config is set to remain that way. My wifi settings have a checkbox to connect automatically and I always verify that when I make a new connection.

I have done that but the settings are not being saved. Is there something that can be done on the terminal with systemd?