Wifi Adapter Not Found

Hello, I will give a quick run-down on the issue:

I installed Fedora on a USB, wiping my previous os (Windows). Everything including the wifi was working properly. I ran root terminal and ran these commands after trying to install something:

$ sudo dnf -y install @development-tools
$ sudo dnf install kernel-headers kernel-devel dkms -y

And I rebooted. After the reboot, the wifi was not working. When I go to the wifi setting it says ‘Wifi Adapter Not Found.’ Anytime I tried to fix the issue, I’m just met with cURL error 6 in the terminal. I ran another OS on a USB and the wifi was working fine, and I even ran diagnostic tests and everything was fine, so this must be a Fedora issue. Is there anyway to fix this? I am a first time Linux user.

Can you show what kernels do you have installed? If you have a half upgraded system where the kernel is upgraded but not its modules, Wifi will probably not work.

Access the GRUB menu and boot from the oldest kernel you have, and report what happens.

Everything works fine booting from the oldest kernel. What do you suggest to do from here?

Boot from the old kernel and perform a system upgrade:
sudo dnf upgrade -y

It could be that you obtained a new kernel without getting its modules, this should fix it.