Wi-fi adapter not finding networks after starting Anaconda

Hello all,

my wi-fi adapter isn’t finding any networks after (accidentally) starting the Anaconda installer and quitting it immediately. Another wi-fi adapter works fine.

I am using the Edimax EW-7811DAC USB adapter with a DKMS driver (rtl8812au). Until recently, it worked perfectly, rebuilding with kernel upgrades and everything.

However, then I accidentally started the Anaconda installer (I was actually trying to start the Anaconda Python distribution). I quit it as soon as the GUI came up, but since then, my adapter isn’t finding any networks. It stopped working the moment I started/quit Anaconda. The adapter shows up in Gnome status bar, everything seems normal, there are just no networks detected.

I’ve tried everything I could come up with: rebuilding via dkms, wiping the driver from the filesystem, redownloading and rebuilding, looking at all the logs I could think of (journald, dmesg), and I can find no indications that anything is out of the ordinary. I was hoping that upgrading from Fedora 30 to 31 would somehow fix the issue, but no luck.
Another USB wi-fi adapter using a different, non-DKMS driver works fine.

I would appreciate any pointers as to where to look next.

uname -a
Linux [REDACTED] 5.3.11-300.fc31.x86_64 #1 SMP Tue Nov 12 19:08:07 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

lsusb | grep -i edimax

Bus 001 Device 006: ID 7392:a812 Edimax Technology Co., Ltd

dkms status

rtl8812au,, 5.3.11-300.fc31.x86_64, x86_64: installed
rtl8812au,, 5.3.6-200.fc30.x86_64, x86_64: installed (WARNING! Missing some built modules!)
rtl8812au,, 5.3.6-300.fc31.x86_64, x86_64: installed (WARNING! Missing some built modules!)
rtl8812au,, 5.3.7-301.fc31.x86_64, x86_64: installed (WARNING! Missing some built modules!)
rtl8812au,, 5.3.8-300.fc31.x86_64, x86_64: installed
rtl8812au,, 5.3.9-300.fc31.x86_64, x86_64: installed

modinfo rtl8xxxu

filename:       /lib/modules/5.3.11-300.fc31.x86_64/kernel/drivers/net/wireless/realtek/rtl8xxxu/rtl8xxxu.ko.xz
firmware:       rtlwifi/rtl8723bu_bt.bin
firmware:       rtlwifi/rtl8723bu_nic.bin
firmware:       rtlwifi/rtl8192eu_nic.bin
firmware:       rtlwifi/rtl8192cufw_TMSC.bin
firmware:       rtlwifi/rtl8192cufw_B.bin
firmware:       rtlwifi/rtl8192cufw_A.bin
firmware:       rtlwifi/rtl8723aufw_B_NoBT.bin
firmware:       rtlwifi/rtl8723aufw_B.bin
firmware:       rtlwifi/rtl8723aufw_A.bin
license:        GPL
description:    RTL8XXXu USB mac80211 Wireless LAN Driver
author:         Jes Sorensen <Jes.Sorensen@gmail.com>
alias:          usb:v0BDAp818Cd*dc*dsc*dp*icFFiscFFipFFin*
== SNIP ==
depends:        mac80211
retpoline:      Y
intree:         Y
name:           rtl8xxxu
vermagic:       5.3.11-300.fc31.x86_64 SMP mod_unload 
== SNIP ===
parm:           debug:Set debug mask (int)
parm:           ht40_2g:Enable HT40 support on the 2.4GHz band (bool)
parm:           dma_aggregation:Enable DMA packet aggregation (bool)
parm:           dma_agg_timeout:Set DMA aggregation timeout (range 1-127) (int)
parm:           dma_agg_pages:Set DMA aggregation pages (range 1-127, 0 to disable) (int)

journalctl when plugging in the adapter

nov 17 14:33:29 [REDACTED] NetworkManager[925]: <info>  [1573997609.0132] device (wlp0s20f0u5u3): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
nov 17 14:33:29 [REDACTED] mtp-probe[10596]: checking bus 1, device 8: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5.3"
nov 17 14:33:29 [REDACTED] mtp-probe[10596]: bus: 1, device: 8 was not an MTP device
nov 17 14:33:29 [REDACTED] systemd-udevd[10590]: Using default interface naming scheme 'v243'.
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <info>  [1573997610.3067] device (wlp0s20f0u5u3): set-hw-addr: set MAC address to [REDACTED] (scanning)
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <info>  [1573997610.3233] sup-iface[0x557b443fbbd0,wlp0s20f0u5u3]: supports 5 scan SSIDs
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <info>  [1573997610.3238] device (wlp0s20f0u5u3): supplicant interface state: starting -> ready
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <info>  [1573997610.3239] Wi-Fi P2P device controlled by interface wlp0s20f0u5u3 created
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <info>  [1573997610.3240] manager: (p2p-dev-wlp0s20f0u5u3): new 802.11 Wi-Fi P2P device (/org/freedesktop/NetworkManager/Devices/13)
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <info>  [1573997610.3243] device (p2p-dev-wlp0s20f0u5u3): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <info>  [1573997610.3249] device (p2p-dev-wlp0s20f0u5u3): state change: unavailable -> disconnected (reason 'none', sys-iface-state: 'managed')
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <info>  [1573997610.3251] device (wlp0s20f0u5u3): state change: unavailable -> disconnected (reason 'supplicant-available', sys-iface-state: 'managed')
nov 17 14:33:30 [REDACTED] NetworkManager[925]: <warn>  [1573997610.3272] sup-iface: failed to cancel p2p connect: P2P cancel failed
nov 17 14:33:34 [REDACTED] systemd[1]: systemd-rfkill.service: Succeeded.
nov 17 14:33:34 [REDACTED] audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-rfkill comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'

dmesg when plugging in the adapter

[ 7208.136601] usb 1-5.3: new high-speed USB device number 10 using xhci_hcd
[ 7208.225015] usb 1-5.3: New USB device found, idVendor=7392, idProduct=a812, bcdDevice= 2.00
[ 7208.225021] usb 1-5.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 7208.225024] usb 1-5.3: Product: Edimax AC600 USB
[ 7208.225027] usb 1-5.3: Manufacturer: Realtek
[ 7208.225030] usb 1-5.3: SerialNumber: [REDACTED]
[ 7208.353880] rtl88xxau 1-5.3:1.0 wlp0s20f0u5u3: renamed from wlan0


wlp0s20f0u5u3  unassociated  ESSID:""  Nickname:"<[REDACTED]>"
          Mode:Managed  Frequency=2.412 GHz  Access Point: Not-Associated   
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


 0 wlan phy0   unblocked unblocked
 5 wlan phy5   unblocked unblocked
  1. Are you using gnome?
    If you are, have you tried using the network settings available in the upper right corner of the screen to reconnect to your wifi access point.

You can look to see if the config is still there or not by checking the files located in /etc/sysconfig/network-scripts and see if you still have the config there. There should be a file named ifcfg-SSID and likely another named keys-SSID which is needed if you use a password to connect.
If those 2 files do not exist then the network manager will not associate the wifi card with the access point as indicated by “unassociated” and the empty ESSID in [QUOTE] wlp0s20f0u5u3 unassociated ESSID:“” Nickname:“<[REDACTED]>” [/QUOTE] from your iwconfig output.

Hi, computersavvy, thanks for your response.
Indeed, I have tried looking at network settings, and there are simply no wifi networks listed, see screenshot.
Also, plugging in another USB wifi adapter I borrowed finds 5-8 networks, including my own, and connects to my network automatically. Unfortunately, this forum won’t let me post more than one screenshot, so I can’t show you.
I have checked for the files you mentioned and they are both present in /etc/sysconfig/network-scripts. Their names contain my ESSID, and their content seems correct. Which makes sense, considering the network does connect with a different adapter.
(Note: the “[REDACTED]” thing in the outputs I posted designates where I removed information for privacy reasons. Maybe that has you confused that there is no ESSID present. It is, I just removed it.).
Honestly, it seems to me like some kind of bug. Merely starting Anaconda should not, imo, disable a wifi adapter, even if its driver is not in the kernel tree.

This looks like maybe the device itself is bad; Possibly the radio has died so it cannot communicate even though what you have posted shows it is seen and (mostly) configured by the system.

You said you borrowed the other device that works so the system itself sees and configures a working device properly. That usually rules out a software issue.

Maybe you should try your original device on another computer. If it works then the problem may be software. If it does not work then figure the wifi device is toast.

I have now tried plugging in the malfunctioning adapter into another, Windows computer at a different location. It works - finds networks and connects. So I guess that rules out a hardware issue.

1 Like

My last suggestion would be to attach the other adapter that works, then while it is active tell the computer to forget the connection.
Once that is done, unplug that adapter and plug back in the one you are having trouble with and see if it now sees the networks and can be activated.

The /etc/sysconfig/network-scripts/ifcfg-SSID file I mentioned earlier identifies the device it activates by both device name and UUID. If the file does not identify the device then network manager is unable to activate the device and the radio is never turned on. This could account for the blank page in the network config you posted earlier.

This is my ifcfg-SSID file where I am currently connected.

ESSID="Meier Media"
NAME="Meier Media"

Different physical devices will have a different UUID and that may be the issue with yours in that you have had 2 different devices attaching to the same access point and using the same device name. The file is for that SSID so the system uses what it has and likely will not work for a different adapter/device. It seems the file remaining may be formatted for the borrowed adapter and not for your own adapter.

Telling the system to forget the wifi connection will erase the existing files and connecting a new device to that access point (ESSID) will create a new file for the current device. Deleting those files by hand, then attaching and connecting the device will have the same effect.

I don’t have or use USB wifi adapters so I cannot test this, but it fits with what I know about the network manager and how it operates.

Hope this helps.

Hey, computersavvy,
I have done as you suggested and forgotten the network with the borrowed, working adapter plugged in. This removed the ifcfg-SSID and keys-SSID configuration files from /etc/sysconfig/network-scripts. Then I unplugged it and plugged in the problematic adapter, but I still could not find any networks.
Thank you for your time, nonetheless.