Why sometimes fedora Log out when in Sleep state and stop recognizing my second monitor?

thanks !

yes

1 Like

All the links and instructions are there for you, if you need help, please let us know.

1 Like

If not already done, there are some steps to follow to enable loading the drivers with secure boot enabled.

If the driver is not already installed then follow these steps.

  1. install akmods
  2. reboot
  3. install the nvidia drivers as linked by @hamrheadcorvette above
  4. follow the steps exactly as shown in the file /usr/share/doc/akmods/README.secureboot to import the newly created key and enroll it in BIOS so secureboot is enabled to allow loading of the nvidia drivers. (on Workstation that requires use of sudo with each command). The actual import occurs with a reboot.
  5. verify the key has properly been imported into bios as shown in that file.
  6. verify the nvidia drivers have been loaded with lsmod | grep -E "nvidia|nouveau" which should now return a list of nvidia modules.

If there is any point in those steps where a problem appears let us know.

If the drivers were previously installed and are not loading then follow step 4 & 5 above. Following the verification of the key in bios then the driver will need to be recompiled using these steps.

  1. remove the kmod-nvidia-<kernel version>package using rpm-ostree (I don’t use silverblue so am not fully familiar with the rpm-ostree command usage for removing packages)
  2. reinstall the driver with sudo akmods --force
  3. reboot
  4. verify the driver loads with the command in step 6 above.
1 Like

thanks guys, very appreciate for your support

i will try to make that shot on the weekend since its my main computer and cant have the risk to get it down these days and i also gonna need some good spare time to make that move since im not tech savy and what i look now through the links you guys sent appears to be very complicated for me, but gonna try

I didn’t provide the Pipewire info since you probably can’t shutdown, so I’ll wait for you to instead install the Nvidia driver and see how that affects the system and proceed from there.

the problem happened again today, losing my open work

sorry, is that akmods ?
https://github.com/ublue-os/akmods/blob/main/README.md

is that the command i need to install akmods ?
sudo rpm-ostree install akmods

sudo rpm-ostree install akmod-nvidia xorg-x11-drv-nvidia

sudo rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1 # this might not be needed at some point when ostree systems will support the standard way to specify this.

these commands ?

1 Like

As a standard practice, I always save the current state of work in progress before leaving the machine. This way even if the same situation you describe happens it is simple to restart and resume from the last saved state.

true, need to get used to do this, i realize that this bug is happening with fedora screen blank option that is set to 15min (the automatic suspend i disable months ago). So i see my computer dimming with my open work and then screen goes black (as it suppose to happen) an then i hit keyboard that lead to gnome login , but when i unlock, was if i just restart the computer everything closed and my second monitor attached to hdmi, stop receiving signal

Please jeff confirm if these steps are right

Steps:
1 - sudo rpm-ostree install akmods
2 - reboot
3- sudo rpm-ostree install akmod-nvidia xorg-x11-drv-nvidia
4- sudo rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1 # this might not be needed at some point when ostree systems will support the standard way to specify this.
5- A file will appear there (after the 4 step) /usr/share/doc/akmods/README.secureboot and i will follow

If something goes wrong even with secure boot , i could rollback to my current state and computer would work as usual (even messing with secure boot) ?

Guide to secure boot in atomic

sudo rpm-ostree install akmod-nvidia xorg-x11-drv-nvidia
sudo rpm-ostree install akmod-nvidia xorg-x11-drv-nvidia-cuda #optional if using nvidia-smi or cuda
sudo rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1 # this might not be needed at some point when ostree systems will support the standard way to specify this.


# If any issue arise, please verify this documentation for updates related to kernel arguments since we cannot update them on ostree systems from the RPM package. This is an ostree limitation (they call it: feature).

Signing the keys on secure boot

1 Like

i should apply live these ?
rpm-ostree install --apply-live akmod-nvidia …

I never used I always follow the guide and I use secure boot so I need to use the secure boot guide/script

thanks so gonna wrap here all the steps:

1 - sudo rpm-ostree install akmod-nvidia xorg-x11-drv-nvidia
2- sudo rpm-ostree kargs --append=rd.driver.blacklist=nouveau --append=modprobe.blacklist=nouveau --append=nvidia-drm.modeset=1
3- rpm-ostree install --apply-live rpmdevtools akmods
4- sudo kmodgenca
5- sudo mokutil --import /etc/pki/akmods/certs/public_key.der
6 - git clone https://github.com/CheariX/silverblue-akmods-keys cd silverblue-akmods-keys
7 - sudo bash setup.sh
8 - rpm-ostree install akmods-keys-0.0.2-8.fc$(rpm -E %fedora).noarch.rpm

I gonna follow exactly these steps, not changing anything.

Is everything right here ? im good to go ?

@hamrheadcorvette @phatle

Looks good can’t remember do I reboot after driver install always and then do secure boot stuff and reboot sign keys it has been some time I last time did this

1 Like

I stated that I am not familiar with ostree commands. You apparently got that from the reference I would need to use myself.

I mean before the git clone, I’d want to know where I was. . . in the terminal “what directory” where am I, The instructions should tell you all you need for that but everything looks good to me.

yes, do you think i need to properly put it on a specific location, or it will be a dump folder, that i could discard after doing the installation ?

And do you know if need to reboot in any of the steps above ?

Installing akmods first then doing the reboot creates the keys automatically.
Installing akmod-nvidia after that reboot ensures the drivers are signed when initially installed.
If you install akmod-nvidia before you have installed the akmods package and reboot then the first build of the drivers will not be signed and the user must perform other steps to have a signed driver module.

The steps I have found to work with minimal extra work is.

  1. install akmods
    (optional to reboot here)
  2. create and enroll the keys into bios as shown by the file /usr/share/doc/akmods/README.secureboot (including the reboot)
  3. install akmod-nvidia
  4. reboot

If akmod-nvidia is installed first it pulls in akmods as a dependency but does not allow for signing the module since the key has not yet been created.

1 Like

All that should be in the git repo instructions. I can’t go through it right now but have a look. What I saw yesterday looked well documented.

Now you mentioned that I remember doing secure boot first sign and install drivers reboot