Why SMT is disabled?

Architecture:           x86_64
  CPU op-mode(s):       32-bit, 64-bit
  Address sizes:        46 bits physical, 48 bits virtual
  Byte Order:           Little Endian
CPU(s):                 96
  On-line CPU(s) list:  0-47
  Off-line CPU(s) list: 48-95
Vendor ID:              GenuineIntel
  Model name:           Intel(R) Xeon(R) Platinum 8168 CPU @ 2.70GHz
    CPU family:         6
    Model:              85
    Thread(s) per core: 1
    Core(s) per socket: 24
    Socket(s):          2
    Stepping:           4
    BogoMIPS:           5400.00
    Flags:              fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm 
                        pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid ap
                        erfmperf pni pclmulqdq dtes64 monitor ds_cpl smx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid dca sse4_1 sse4_2 x2apic
                         movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb cat_l3 cdp_l3 i
                        nvpcid_single pti intel_ppin ssbd mba ibrs ibpb stibp fsgsbase tsc_adjust bmi1 hle avx2 smep bmi2 erms invpcid rtm c
                        qm mpx rdt_a avx512f avx512dq rdseed adx smap clflushopt clwb intel_pt avx512cd avx512bw avx512vl xsaveopt xsavec xg
                        etbv1 xsaves cqm_llc cqm_occup_llc cqm_mbm_total cqm_mbm_local dtherm ida arat pln pts pku ospke md_clear flush_l1d 
Caches (sum of all):    
  L1d:                  1.5 MiB (48 instances)
  L1i:                  1.5 MiB (48 instances)
  L2:                   48 MiB (48 instances)
  L3:                   66 MiB (2 instances)
  NUMA node(s):         2
  NUMA node0 CPU(s):    0-23
  NUMA node1 CPU(s):    24-47
  Itlb multihit:        KVM: Mitigation: VMX unsupported
  L1tf:                 Mitigation; PTE Inversion
  Mds:                  Mitigation; Clear CPU buffers; SMT disabled
  Meltdown:             Mitigation; PTI
  Spec store bypass:    Mitigation; Speculative Store Bypass disabled via prctl
  Spectre v1:           Mitigation; usercopy/swapgs barriers and __user pointer sanitization
  Spectre v2:           Mitigation; Retpolines, IBPB conditional, IBRS_FW, RSB filling
  Srbds:                Not affected
  Tsx async abort:      Mitigation; Clear CPU buffers; SMT disabled
cat /sys/devices/system/cpu/smt/control
[core@host ~]$ sudo echo on > /sys/devices/system/cpu/smt/control
-bash: /sys/devices/system/cpu/smt/control: Permission denied

Why is SMT disabled and how to enable it?
Hypertrading is enabled in the bios.

Fedora release 36 (Thirty Six)
NAME="Fedora Linux"
VERSION="36.20220522.3.0 (CoreOS)"

Hi @nexcode - We set the mitigations=auto,nosmt kernel arguments for Fedora CoreOS in order to default to servers that are more secure (see #181). You can change this setting, though. See this set of documentation for how to do that.