Why is Calibre not updated from version 4 to 5 in the official repo?


The latest version of Calibre is 5.21. Why is it then the case that Calibre in the official repo is stuck on version 4.23?

4.23 that’s offered in Fedora: calibre | Package Info | koji

5.21 is the latest: Releases · kovidgoyal/calibre · GitHub

Calibre 4.23 was released in Aug 21, 2020. 5.0.0 was released in Sep 25, 2020.

I don’t understand why they haven’t updated Calibre during all this time?

1880754 – calibre-5.22.1 is available

1 Like

I’ve used Calibre a lot install it from flatpak

flatpak list | grep calibre
calibre	com.calibre_ebook.calibre	5.21.0	stable	system

How to install it:

flatpak install  com.calibre_ebook.calibre

Regards., HTH

1 Like

Hmm, too bad… Seems like they aren’t able to build its dependencies…

Other than that it seems to just be spam from the upstream project about new versions.

But thanks anyways daddy, I hope they manage to sort it out. I prefer when Fedora is more up-to-date.

1 Like

Ah, interesting. I haven’t used Flatpak before. I’m trying to search for it, but that doesn’t return any results:

$ flatpak search calibre                  
No matches found

I wonder who’s the one that publishes that package, if it’s the project owner or just some random person?

King Kong

1 Like

Is from the official calibre owner just add flathub repo is where app. Live


flatpak remote-add --if-not-exists flathub https://flathub.org/repo/flathub.flatpakrepo

And try to install again or search…

Regards., Hth

Thanks daddy! Didn’t know about Flathub. Looks like a nice package repository. I will try that out…!

Best regards,
Silver Kong

Daddy I have now tried it. And. It. Worked. Good that I don’t need to trust Fedora anymore with compiling dependencies for packages and reading Bugzilla about non-existing progress. This is really nice.

1 Like

I’m not sure the intention is here, but could you please not refer to others on the forum as “Daddy”? It’s quite unusual and can have negative meanings in many cultures/languages. Thanks

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.