Why Fedora Server 37 now asks for a root user?

Hello Community

I remember years ago that with Fedora Core for the release between 12 and 14 the root account was removed due security reasons, same experience so far with Fedora Workstation and Server 36, but just few minutes ago, I tried to install Fedora Server 37 through VirtualBox and I have the following experience:

From above observe the Root Account message in red and the Begin Installation button is disabled. if the Root Account icon is pressed then appears the following screen

I am not sure if it is a bug, but it seems that now is mandatory select the Enable root account radio button. If is not selected then is not possible enable the Begin Installation button, see first Figure.


  • Why Fedora Server 37 now asks for a root user? or is it a bug?

Thank You.

The system forces you to decide if you need a root account to manage your system remotely. If you decide to Disable the root account you have the chance to create a local user with sudo rights.

This generally is used if you will send the user certificate of an existing user to the server to log in remotely by the specific user.

This means you will have to set a password for the root user before you can use it afterwards.

It not looks like as a bug, more as a feature.

Strange when i compare with the manual it looks different.

Probably now on the first login you will be asked to create a new user ?! Can you confirm this?

Indeed under the “Root Account” spoke there should be a “User Creation” spoke, like here:

Just wondering: maybe the virtual box window is too small? Maybe you can scroll down the installation window?


Interesting and yes, the User Creation option was below - curious because the vertical scroll bar did not appear from the beginning. It was not intuitive.

Apropos, the second time this weekend I would propose to use the Anaconda Testing to do a Installation to see if this Issues would be solved.

Does anyone know how to do/use it. I just remember the announcement but don’t remember how to do it.
Or is it just available for rawhide?

Yes, I expected this behavior as I experienced with the release 36. Same as Ubuntu too.

Therefore for the first non-root user created through the installation process it has the sudo rigths/privileges. And well, if is executed the sudo -i command using the password of the first non-root user is possible change to “root” in peace.

If it is about the Root Account, could you expand the idea? I don’t understand your information.

For remote connections, normally I use the first non-root user with SSH. I want have clear the complete picture about when would be mandatory use this new feature.

Thanks in advance.



In the case you enable root account ,if I’m not wrong, by default ssh will allow root login (via ssh) only with an ssh key pair.