Why doe my hard drive not apear during instalation?

I am currently triing to turn an old PC into a NAS. I’ve bought a new Hdd in order to sotre the files, but when I try to intall Fedora server It does not find any disc. Why is that so?

I-ve tried checking in the bios and the new hard drive apearas as a bootdevice. When changen the Sata mode to AHCI (like I read in a forum) I found that all sata ports are empty. But the disk is picked up by the boot window and it spinns up whenever I power the pc. What can I do for te hard drive to be recogniced?

Hello @queku ,
Welcome to :fedora: !
Your BIOS is showing nothing connected to the SATA ports (empty). Are you sure the physical connection is solid?

1 Like

I have the same question. Looking at the screenshot :

The Sata Power is connected so yes, the drive should spin on boot !

The Sata data cable is also connected to the HDD, but I see empty Sata connections on the board.

Well, even on my old boards with SATA there is always at least 4 physical connectors so there could be two more under the wires. But I would check connections, and the SATA connector on the drive seems to be proud of the power connector, implying not seated firmly. I have also had issues with SATA cables from different case suppliers and board suppliers not working at all.

1 Like

I have old boards with only 2 SATA (AMD AM2 MoBo) but to not derail this thread with hardware quirks, I absolutely agree to assure the connections are good. Also, try a different Sata Port if need be, it could be a bad port on the board.

True enough. But it isn’t a derailment until …

Yeah, first thing I tested was changing the wires and disconnecting and connecting it again

This board has 6 ports, 4 oranges and 2 white. My sata cable was first connected to the white one and I switched to the orange one and still no change in the boot up process.

Is this an ASUS board? Do you have the datasheet for it? Possible the white are different speed? Also, I think you can use SATA mode in the BIOS.
[Edit] Also, with older BIOS’s, switching from SATA to AHCI can cause issues with the drive since AHCI requires extra drivers. See this Dell KB topic Difference Between AHCI and SATA | Dell Canada

Did the system work with a SATA drive in the past? Can you share the model number? Have you checked the LHDB? Did you buy it from a reputable dealer? Did you tell the dealer how you intended to use it?

Older BIOS may not support large capacity drives. Have you checked for BIOS updates?

There should be a manufacturing date on the case. Sometimes drives that have been sent for recycling (and electronically disabled) end up being sold as new. Some drive firmware is only works with specific systems (e.g., proprietay laboratory instrumens). You should be able to check with the manufacturer. dmesg may have some details.

I got the pc from my informatics department when they where renovating the infrastructure. I was told the device was old (10+ years) but still usable, but still haven’t been able to load an os.

How can I update the BIOS? I just simply bought a 1TB hard drive and only thought to check for sata compatibility.

In the bios I only get the following options for SATA Mode:
I was told I should put it in Ahchi, since Raid requires at least another drive. But I dont know what IDE mode is. Could it work with it?

Can you change the SATA Mode in the BiOS to IDE, that is what an older BIOS can more easily recognize a HDD with since 10+yrs ago, AHCI was more for SAS and early NVMe / SSD’s.

See if you can use to change the selection.

AHCI is for SATA. Setting to AHCI is the right choice. IDE will not work for a SATA drive.

NVMe is a standard that replaces AHCI.

I wonder if the BIOS needs resetting. Find the reset to defaults option, use it, and reboot.
Then check the setting again.

Some systems of that vintage were limited to 2TB. 1TB should be fine. BIOS updates come from the system vendor, but many won’t provide updates for systems that old. See AMI BIOS UEFI Utilities for descripton of what might be available.

Modern SATA drives support AHCI, which is why it would help to see the model and date of manufacture. Your image cuts of the copywright data for the Aptio Setup Utility which might be a hint to the age of the BIOS.