Why can't I print properly from HP printer?

I have a problem,

I am trying to print from my HP printer. (I have HPLIP installed.) HPLIP was the only way I could even get my printer to work at all. I use fedora with xfce. (Although I do find it strange that back when I used KDE I was able to get to printer to work without HPLIP.) The Printer is an HP Deskjet 4155. Whenever I try to print the printouts always start at the top of the page and leave a big gap at the bottom where nothing will print. I have tried printing directly form LibreOffice, converting to PDF and printing from Firefox, and printing the PDF from HPLIP. HPLIP has given me the best results so far as no text has gotten cut off, but prints still start at very top of page and leave a big gap at bottom. Firefox and LibreOffice both cause text to get cut off or not print correctly. I have tried to play with settings from all three and can’t get any improvements.
I know that other people are able to print from Linux, but I am not having much luck. Below I will post screen shots of the settings and some printouts that I did. Please note that some of the bad print quality is most likely due to my printer being low on ink and the ink cartridges are just the free ones that came with the printer as I don’t use the printer much, but I have gone trough a lot of ink printing test pages trying to get see if I could fix the problem and also trying to just get a good printout for the few times that I have needed to print something, and I had to reprint about five times before I got a copy that was good.

Does anyone know why my printouts are like this? Is anyone able to get good prints from Linux?
Is the problem my printer or the print driver? What printers work good with Linux?

I have not yet tried to print from a Windows PC. I have thought about doing this and just using the windows PC for printing and nothing else. But I don’t like Windows and it would be much more convenient to be able to just use one computer.

I know this most likely would not work, but would it be possible to run the Windows HP software using WINE and print from that?

Any ideas what to do?

Try installing cups and the foomatic packages. Or find a ppd file for your model online and use that.

It looks to me like you may have the margins set incorrectly. My laserjet printer has an unprintable (~1/8 in) margin on all 4 edges and automatically prints within that boundary.
Your displayed test print appears to be starting at the edge of the paper rather than at the beginning of the printable area, which shows the print driver may be incorrect. Some printers are capable of starting print at the edge of the paper and others are not. The driver determines how the print is configured before it is sent to the printer.

This picture shows how mine is set for the 8.5 x 11.5 paper. If yours is not set that way and changing it as shown does not work, then one method that has worked for me is to first delete the printer config within the gnome settings → printer control panel, then reboot. After the reboot once again configure the printer using the hplip gui. This delete then reinstall and reconfigure usually fixes a corrupted printer configuration.

If that does not work then come back and show us the result of the test page print again so we can try something else.

Also show us the driver installed, which will be a .ppd file in /etc/cups/ppd/

1 Like

Hi, here is what I did.

I completly removed the printer from my computer and restarted.
Added it back with HPLIP. (see screen shots below)
HPLIP defaults my printer to 8x10 and only give my the option for 8.5x11.
You can see in one of the screenschot the driver that is used and can see that it is one provided by HPLIP as none of the built-in Linux ones work.

I created a test document in LibreOffice(Please ignore the black text part my ink is very low)
LibreOffice for some reason will default my printer to support 8x10 and on the print config page sets the page to 8.5x11.
I tried a few prints with some different settings.(see below)
I also included screenshots of the previews of the prints from LibreOffice so you can see how LibreOffice says they should have come out.

First I tried with everything set to 8x10.
Then with everything at the default way the software sets it.
Then with everything set at 8.5x11.

I also printed to a PDF and tried to print the file from HPLIP.(the last image)

Every print I did will always cut off at the same point leaving a big gap at the bottom of the page where it refuses to print to.

It puzzles me that you would have a printer and paper of standard letter size ( 8.5 x 11) but you somehow have libreoffice configured for 8x10. Does that mean the margins are set at 8X10 or that it is set for paper size of 8X10?
I clearly see that in the printer config you had selected paper size of 8x10, then you changed that to 8.5x11.

I have never seen that particular test layout, so where did it come from? Libreoffice?

My default config for libreoffice has always been letter size with 0.79" margins on all 4 sides and everything has always worked.

It seems some printers (especially inkjets) are able to set the printable area of the page and thus may be able to print starting at or even above the top of the page with no margins when doing photo printing. Does that one by chance have the ability to set the top margin within the printer itself? What you are showing seems definitely to be either printer driver or printer configuration related. The 8x10 paper size is a standard photo size.

What happens if you use the printer control panel and tell it to print its own self test page? That will do a test that may separate the issue from the driver and isolate it to the printer itself.

Similarly the printer itself should have a setting for the default paper size so check that it is properly set for letter size paper and portrait orientation as well.

I did not set anything to 8x10 all the Linux side software does that automatically. I went into HPLIP and set the printer to 8.5x11 and LibreOffice/Firefox still defaults to 8x10. But that still would not explain why it prints the way it does even when I set everything to 8.5x11. When I tested on a windows PC everything works fine.

I tested on a windows PC and the HP Smart app shows the printer is set to 8.5x11. After creating a PDF file from LibreOffice then moving to the windows PC I tried to print it and the print came out perfectly and it even had better colors. I did print a test page from HPLIP as you can see in my top post, and that seems to print fine for the most part except you can see where some of the text got cut off for some reason.

My test with the windows PC tells me that the problem is with Linux HPLIP or both.
One way I could get around this is to convert any document I need to print to PDF then move the a windows PC and print it from there, but I would like to automate the process to all I have to do is send the file and it will print with out me needing to interact with the other PC. Sadly windows does not seep to support printing files from CMD or script file.

I don’t know what to do. I have tried messing with all the settings and can’t get it to work right, but other people have no problem printing from Linux, and windows is garbage that does not support scripting like Linux does.

My next question is this.
Are you using the hplip and hplip-gui that are available from the fedora repo? or did you download & install hplip from their download site?

Hplip is installed by default when fedora is installed, and hplip-gui is available for install with dnf install hplip-gui. I never seem to have any problems with hplip for HP printers.

There is one other issue that I encountered. That was that ‘avahi’ always seemed to create an additional printer definition that did not always work. I uninstalled avahi and that stopped the extra printer definition from being created so the only printer available was the one I defined from within hplip and I have had no problems since.

1 Like

I installed it using dnf.

One big difference seems to be that you use Fedoa with Gnome(Fedora Workstation). I use the Xfce Spin. I dont know why but the Xfce Spin seems to work a little differnet from the other downloads. For example: before I switched to Xfce I used the KDE Spin and with that Spin I was able to get the printer to print a test page without needing to first install HPLIP(I never tested printing documents), but with the Xfce Spin the only way for me to even get a test page to print was to install HPLIP. I have no idea why I got different results like that.

I thought about trying a live boot of the normal Fedora Workstation to see if it gives me any different results.

I just tried loading a live boot of the normal Fedora Workstation and tried to print a pdf file from it.

The good news is that the prints were not starting at the top of the paper, but no matter what I did the prints all had parts that were cut off or did not print at all.

Perhaps the driver just does not work well with this model of printer. What model of printers do you use?