Why are MP3 files opened with Videos?

This is bugging me for quite some time. Whenever I double click an MP3 file in Files, the file will be opened with Videos, which is a bit strange, as default application for music files is Rhythmbox.
As this happens on a freshly installed Fedora Workstation, I was wondering if this is a bug or intended behavior?

The default DE with Fedora Workstation is currently Gnome 42. So, looking for Gnome 42 Mime type settings (i.e. filename-endings, such as mp3 related to apps or programs opening these files) would perhaps solve the issue:

Select a file of the type whose default application you want to change. For example, to change which application is used to open MP3 files, select a . ...
Right-click the file and select Properties.
Select the Open With tab.
Select the application you want and click Set as default.
1 Like

Cool, thanks! Didn´t think of that, as I was too focused on Gnome Settings’ Default Applications. And was afraid to dig into any Mime config files.

Still, I don’t know why default application is Videos.
Could it be because MP3 isn’t as free as OGG and thus ignored in Fedora?
(I see that OGG files are opened with Rhythmbox by default)

in /usr/share/applications/gnome-mimeapps.list
the entry, audio/mp3=org.gnome.Totem.desktop;

This is setup from the gnome-desktop installation, you can see in the sources in the spec file and then they are concatenated together

you can copy it to ~/.local/share/applications/ and modify if you’d really like to or go with the much simpler route @anon71016743 suggested.