White desktop after update

I think a recent update broke gnome on my other PC.


  • After logging in, my desktop turns white. This includes the menu bar and any open screens, but not the cursor.
  • Initially there are intermittent flickers of the desktop. Allowing a few minutes in which it is sort of possible to use the desktop. These flickers seem to become less frequent the longer the computer is on, with the desktop becoming solid white (except for the cursor) eventually.
  • The login screen and tty sessions (CTRL-ALT-F3) are not affected.
  • When I went to settings > about, the gnome version was listed as UNKNOWN (my reason for suspecting gnome). It is now listed as 43.3.

System configuration

  • Fedora 37 workstation edition (64-bit).
  • AMD Ryzen 7700X processor, using the integrated GPU via USB-c.
  • 64GB RAM.
  • 4TB SSD.
  • Unused Radeon 6900X GPU. (Used for passthrough to VM’s. Running a VM with the passthrough does still work.)

What I’ve tried

  • Turning it off and on again. Didn’t help.
  • The other GNOME modes from the login screen (GNOME Classic, GNOME Classic on Xorg, and GNOME on Xorg). Didn’t help. Xorg made it worse (instant solid white, instead of flickers of the desktop).
  • dnf history undo last. Didn’t work, the old packages (kernel, firefox, gnome-maps) are no longer available.
  • Running a Fedora live USB. Works, but I would rather not wipe my current install.

Can anybody help me? I don’t know a lot about gnome or windowing systems, so I’m not sure where to even begin to debug this. I’m not afraid of using the terminal. As I am typing this from a second computer, posting entire logs will be a challenge.

1 Like

Some of these glitches may go away with updates. You can use the tty to run sudo dnf check-update to list available updates. If any lokk useful, use sudo dnf update to install them (and reboot to get the changes running).

If both systems have working network access, you can capture data on the broken system and transfer it to the other box.

Start with journalctl -b in the tty to look for errors related to your display hardware. These should also appear in dmesg output (dmesg uses a ring buffer, so you may need to increase the size of the ring buffer on the kernel command line – you may need to learn some useful basic procedures to do this – ask if you need help with them). In the tty session run dmesg > dmesg.log and use sftp, etc to copy the file to the other system.

1 Like

No useful looking updates (only tar).
No logging suggesting errors with the display hardware.

Update: I tried KDE, and that also gave the white desktop. So I guess that it’s probably not gnome that is the issue. It’s also not Wayland, since X also has the issues. And I don’t think it’s a hardware problem because the login screen and cursor are not affected.

I am quite stumped by this problem, so if anyone has any clever ideas please speak up.

I found a solution, apparently it was a lack of VRAM. The vital clue was that setting my display to picture-by-picture mode (effectively halving the resolution) seemed to fix the problem. The ‘auto’ setting of my BIOS seems to allocate 512MB VRAM. After setting that to 1GB, I have a working desktop on the full 4K resolution of my monitor.