When secondary screen is connected desktops switch at the same time

when using a secondary screen when I use a touchpad with 3 fingers to switch between desktops it switches on both screens. so if I’m using the 2nd desktop on the first screen I have to use the 2nd desktop on second screen as well.
For example, can’t use desktop 1 on the first screen and desktop 2 on the second screen.
don’t know if I could explain. if not can record the screen.

If I understand what is happening is that you have activated the option “Workspaces on all displays” but when you change workspaces they all change together. But you want each screen to have its own workspaces, don’t you?

It is not a bug, it is the way GNOME works. They are trying to implement a “workaround” for this but they are still discussing how to implement it.


yess that’s exactly what i need. like macs