When I view the task bar (Alt-TAB) it is very hard to see which is selected

I wasn’t able to provide a screenshot yet. I tried with Fedora screenshot utility but I found that whenever I am using it Alt-Tab does not work. However it comes up with the icons with a very dark background and the selected icon has only a very faintly discernible difference to the background. Does anyone know how to change the background colour for the selection icon while alt-tabbing through the open apps?

1 Like

Hi @kiwiheretic . Could you provide some more information please? Is this on Gnome, what version of Fedora? Have you customised the UI in anyway—extensions, themes, icon packs?

Could you also please create a new user and see if the issue persists?


I will try taking a photograph with my mobile camera if I can figure out how to do that with two hands.

Ok I think I have managed to get the photos.

The second photo shows what I mean when I say I cannot see which app I am alt-tabbing to because the change in background is so faint.

Yes, it is on Gnome, no customisations except I think I changed the screen resolution to make the font size bigger. I haven’t changed the theme, extensions or icon backs. Will try a new user when I get back home to see if it persists.

1 Like

You can use text scaling factor to make fonts bigger if necessary:

gsettings set org.gnome.desktop.interface text-scaling-factor "1.25"

Screen resolution is best to revert to the standard one for your display.
Artifacts and glitches are more likely to occur in non-default modes.

It’s really the background behind the alt-tab icons for the currently selected icon that I want to change.

Sure, I can try reverting back to default screen resolution but am surprised that this affects things like background colours.

1 Like

Here it is with the screen resolution reverted captured in video this time so you can see it better. YouTube video showing Alt-Tab problem.

I don’t know if this is an unsolved problem with Gnome. If I should be using a spin perhaps you could advise me which one. At my age I do find myself relying on desktop zoom quite a bit.


Yeh, that’s quite odd. It looks fine on my machine here:


Can you try creating a new user to see if the issue persists? That’ll tell us if it’s a system package issue or something related to the user configuration.

1 Like

It depends on the contrast of your monitor.

But I agree, Gnome can use different color instead of different brightness to indicate which app is “selected” to improve the readability.

1 Like

Ok I created another user and made no settings changes and took a screenshot with my phone. It still looks the same. Should I be looking at another spin desktop or is there a way of tweaking the alt tab background.

I think this is not really a Fedora specific issue, but something GNOME related, i.e. Adwaita/libadwaita or GNOME Shell.

I recommend creating a topic here:
GNOME Discourse - GNOME discussions

Or try to contact the developers directly:
Issues · GNOME / libadwaita · GitLab

It’s all the more worth filing a ticket since the high contrast accessibility setting does not help solving the problem.

Maybe it is not gnome specific and I have done some googling of my own and on StackExchange it looks like an unsolved issue even offering bounty for a solution. I am not 100% sold on Gnome as I am coming from Zorin where most things just worked. I am open to other themes and spins if that at least gets me up and running.

I may have found a partial solution to the problem although it wasn’t really in the spirit of finding a simple answer to a simple problem.

I had to install Gnome Extensions. Then I was able to install “CoverFlow Alt Tab”. Its kind of over kill for what I wanted but it now does show me the currently selected task in a very clear way.

That was after trying other spins on a live USB boot situation which often added as many issues as it solved so I think best to stick to one flavour for as long as feasible.


I don’t know if it would help, but I found that the program /usr/bin/gddccontrol can be helpful to optimize the contrast and brightness of your monitor. The program is found in the package ddccontrol-gtk.

Switching to dark theme or or the other way around might also make a difference.

1 Like

I found it in the vanilla Fedora install there are very few theme options. I think I counted only two. One light, one dark.

Fiddling with the contrast might have worked but of course that affects everything. I think the option that I have chosen seems less disruptive.

1 Like