What do you do when a Fedora desktop freezes?

F29 freezes few times on a Sony VGN-AW21M, I shutdown the pc and start again.

  1. What do you think is the most reason of that issue?

  2. What is the safe method and most used by you to fix that issue?

1 Like

There are generally two main issues which may be the culprit: 1) bad RAM 2) or video driver trouble.

To rule out RAM, I recommend booting memtest86 and letting it run overnight.

Video is a little trickier. Not sure what hardware this laptop has, but if it’s Nvidia and you’re using Nouveau, try the proprietary driver. If you’re already using that, you’ll need to check with Nvidia for help as we can’t do much.

To help diagnose further, run journalctl --priority=err --since=yesterday to see all errors logged in the past day. If you see any, remove --priority=err to get more info.


I see that this laptop does use Nvidia, so unfortunately that’s likely the main culprit. We’ve done some work to make it less of a pain to use the binary proprietary driver so hopefully that will help.

In the future, if you have the option, I recommend getting a laptop with Intel or (if you can find it!) AMD Radeon graphics. These work beautifully with pure open-source drivers (even for gaming).

One other thing you can try is to update the BIOS. I don’t think Sony participates in the Linux Vendor Firmware Service (created by people on Red Hat’s desktop team, btw, but made to help all Linux users). This means that you’ll probably have to boot into Windows to do that update (if one is even available). In my experience with Thinkpad and Dell systems, this rarely results in something as bad as freezes, but can help with issues like audio crackling or docking station woes.

1 Like

I didn’t find an appropriate time to test the ways you mentioned @not-mattdm-at-all, and as a first task I see the pc needs a cleanup for the internal materials (RAM, Fans…), then go with testing RAM and video driver.

Thank you Matthew

If the issue is heat due to dust (or cat hair or whatever) inside the computer, you will probably see heat-related errors in the log.

I posted the pc for maintainer to cleanup, unsure about heat errors. let’s these until finishing the cleanup.

I got the pc today and I run the following cmd:

[tarik@localhost ~]$ sudo lspci -v -s 01:00.0
[sudo] password for tarik: 
01:00.0 VGA compatible controller: NVIDIA Corporation G98M [GeForce 9300M GS] (rev a1) (prog-if 00 [VGA controller])
        Subsystem: Sony Corporation Device 9040
        Flags: bus master, fast devsel, latency 0, IRQ 26
        Memory at d2000000 (32-bit, non-prefetchable) [size=16M]
        Memory at c0000000 (64-bit, prefetchable) [size=256M]
        Memory at d0000000 (64-bit, non-prefetchable) [size=32M]
        I/O ports at d000 [size=128]
        Expansion ROM at 000c0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 3
        Capabilities: [68] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [78] Express Endpoint, MSI 00
        Capabilities: [100] Virtual Channel
        Capabilities: [128] Power Budgeting <?>
        Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
        Kernel driver in use: nouveau
        Kernel modules: nouveau

I downloaded the Linux X64 display driver and I run the following:

sudo sh ./NVIDIA-Linux-x86_64-340.76.run --no-x-chec

I got the message:

For some distributions, **Nouveau** can be disabled by adding a file in the modprobe configuration directory.  Would you like nvidia-installer to       
  attempt to create this modprobe file for you?

I was able to replicate the issue which was in two main things:

  1. Desktop freezes. (issue found related to high usage of ram)
  2. Vertical lines on screen after booting.(not found after installing NVIDIA display driver).


The process I did while installing NVIDIA had some cmds from this post.