Weird kernel "upgrade" from 5.3.5 to 5.3.4

I’m on the 31 Beta and have been running kernel 5.3.5-300 for several days without problems.

This morning, I ran “dnf upgrade --refresh” and it upgraded my kernel backward to 5.3.4-300. When the system rebooted, 5.3.5-300 was still at the top of the grub list, but 5.3.4-300 was pre-selected and that is what ran without manual intervention.

This all seems very strange. Any ideas?

1 Like

Happened to me too. I think it is normal. Actually for me 5.3.4 works better than 5.3.5 which freezes on shutdown.


kernel-5.3.5-300.fc31.x86_64 is installed

sudo dnf upgrade --refresh shows anything - my update mirror is in Germany I guess-
sudo dnf distrosync

would do an downgrade to kernel-5.3.4-300.fc31 !

to compare the active repos:

grep enabled=1 /etc/yum.repos.d/*


1 Like

Hi all is ok the backward happened 2-3 days ago, when gnome-software did need a downgrade of version, what forced to this backward, after of this the kernel 5.3.4 is in the “stable” branch while the 5.3.5 is not active and is fixed to the updates-testing.

[jorge@fedora31 ~]$ dnf list --installed kernel
Installerade paket
kernel.x86_64              5.3.0-0.rc6.git0.1.fc31              @anaconda       
kernel.x86_64              5.3.4-300.fc31                       @fedora         
kernel.x86_64              5.3.5-300.fc31                       @updates-testing

For me 5.3.5 worked great and fast like the last version of mesa (really nice), but mesa was downgraded too, between other things there was a problem with rendering in google-chrome (I belive remember)

But all is ok.


Ok, thanks everyone. Since I never run Chrome, I must not have experienced the problems others may have been having.

It is curious that on my other system, which runs Arch Linux, I am having the failure to reboot problem (and it continues after this morning’s upgrade to 5.3.6), but Fedora 31 Beta on my notebook has been running, perfectly.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.