Weird boot/shutdown quirks (related to flicker-free boot)

My system was upgraded from Fedora 29 to Fedora 30 and I noticed that flicker-free booting was a new feature coming with Fedora 30. Unfortunately, my installation has anything but a flicker-free boot. I see the UEFI splash and then I see the normal systemd output (the OK messages; bonus points to whoever can tell me what those are called) until Plymouth starts right before the LUKS password prompt. I noticed that Plymouth still had the old “charge” theme which I changed to the “spinner” theme with no change.

Is there any way I can get this flicker-free boot to work before the LUKS password prompt?

cat /etc/default/grub

What does it say?

Hi @jdloft! Welcome to the community! Please have a look at the introductory posts in the #start-here category if you haven’t had a chance to do so.

Have you rebuilt your initrd image after changing plymouth theme? As far as I understand, you need to in order for change to take effect.

$ sudo plymouth-set-default-theme tribar -R
Note that the -R flag will rebuild your initrd, and the next time you reboot your system, you will see the new theme in action.

Here’s more details about changing plymouth themes in a Fedora magazine article.

As far as I understand, the answer is “maybe”. A pair of quotes from Fedora FlickerFreeBoot wiki page:

Please keep in mind this is still a work in progress.

Take a machine with i915 graphics (amd/nvidia graphics will still see the monitor turn off briefly for now)

Also I can say that on my notebook with older i915 graphics and encrypted root, /home and also temp partition, the boot process is quite close to flicker-free when I reboot my machine (and I see a graphical LUKS passphrase request on after reboot), but on an initial powerup LUKS passphrase request is in text mode. I think that’s because I have my temp partition encrypted in addition to root and /home as that’s not the default. But I haven’t tried to troubleshot it.

GRUB_DISTRIBUTOR="$(sed 's, release .*$,,g' /etc/system-release)"
#GRUB_CMDLINE_LINUX="rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1 resume=/dev/mapper/VG1SSD-SWAP rd.luks.uuid=luks-9567d6d6-64ce-4628-a61e-e08269b07973 rhgb quiet"
GRUB_CMDLINE_LINUX="resume=/dev/mapper/VG1SSD-SWAP rd.luks.uuid=luks-9567d6d6-64ce-4628-a61e-e08269b07973 rhgb quiet"

I sometimes enable the Nvidia drivers but they have no effect on this.

Yes, initrd has been rebuilt. I can see that the theme does change but still doesn’t start before the LUKS prompt.

You need to either comment out this string, or change it to “gfxterm” instead of console. It’ll help a bit.

From the quote I’ve provided I read that you can’t have flicker-free boot on NVidia hardware regardless of drivers. Both nouveau and proprietary drivers need some work in order to make flicker-free boot possible, as far as I understand.

Just out of curiousity: is this identical for both initial startup (from powered off system) and for reboot/restart? I’m asking because I saw a difference in my case – wrote about it above )

1 Like