WebKitWebProcess crashed

Process 3393 (WebKitWebProces) of user 1000 dumped core.

Module /usr/libexec/webkitgtk-6.0/WebKitWebProcess from rpm webkitgtk-2.44.1-1.fc40.x86_64
Module /usr/lib/x86_64-linux-gnu/webkitgtk-6.0/injected-bundle/libwebkitgtkinjectedbundle.so without build-id.
Module /usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-6.0.so.1.3.1 without build-id.
Module /usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-6.0.so.1.3.1
Module /usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 without build-id.
Module /usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0
Stack trace of thread 2:
#0  0x00007fe467aa3e14 n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x90e14)
#1  0x00007fe467a51dce n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x3edce)
#2  0x00007fe467a3983f n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x2683f)
#3  0x00007fe4682d37ef n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x6d37ef)
#4  0x00007fe46a458162 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2858162)
#5  0x00007fe46a34c75c n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x274c75c)
#6  0x00007fe469883d5c n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x1c83d5c)
#7  0x00007fe46a85ade1 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2c5ade1)
#8  0x00007fe46a860571 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2c60571)
#9  0x00007fe46a85fe7e n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2c5fe7e)
#10 0x00007fe46a86ac46 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2c6ac46)
#11 0x00007fe46a8706f2 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2c706f2)
#12 0x00007fe469a9d2b8 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x1e9d2b8)
#13 0x00007fe469a9dcb2 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x1e9dcb2)
#14 0x00007fe469abb61d n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x1ebb61d)
#15 0x00007fe469e44ffe n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2244ffe)
#16 0x00007fe469e495a1 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x22495a1)
#17 0x00007fe469e4ae97 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x224ae97)
#18 0x00007fe469fffa01 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x23ffa01)
#19 0x00007fe469ffebc0 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x23febc0)
#20 0x00007fe46a008717 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2408717)
#21 0x00007fe46a008b02 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2408b02)
#22 0x00007fe46a020ad4 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x2420ad4)
#23 0x00007fe46a14dbb0 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x254dbb0)
#24 0x00007fe4689981c4 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0xd981c4)
#25 0x00007fe46896f78b n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0xd6f78b)
#26 0x00007fe46896dc63 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0xd6dc63)
#27 0x00007fe46889f19b n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0xc9f19b)
#28 0x00007fe4683cc96e n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0x7cc96e)
#29 0x00007fe46866b4c5 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0xa6b4c5)
#30 0x00007fe46866b664 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0xa6b664)
#31 0x00007fe467190fdb n/a (/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-6.0.so.1.3.1 + 0x1590fdb)
#32 0x00007fe4671f6acd n/a (/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-6.0.so.1.3.1 + 0x15f6acd)
#33 0x00007fe4671f5c31 n/a (/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-6.0.so.1.3.1 + 0x15f5c31)
#34 0x00007fe463612647 n/a (/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0.8000.0 + 0x60647)
#35 0x00007fe463614767 n/a (/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0.8000.0 + 0x62767)
#36 0x00007fe463615117 n/a (/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0.8000.0 + 0x63117)
#37 0x00007fe4671f6211 n/a (/usr/lib/x86_64-linux-gnu/libjavascriptcoregtk-6.0.so.1.3.1 + 0x15f6211)
#38 0x00007fe4689bae47 n/a (/usr/lib/x86_64-linux-gnu/libwebkitgtk-6.0.so.4.7.0 + 0xdbae47)
#39 0x00007fe467a3b08a n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x2808a)
#40 0x00007fe467a3b14b n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x2814b)
#41 0x000055f453053085 _start (/usr/libexec/webkitgtk-6.0/WebKitWebProcess + 0x1085)

Stack trace of thread 4:
#0  0x00007fe467b2794d n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x11494d)
#1  0x00007fe4635db65b n/a (/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0.8000.0 + 0x2965b)
#2  0x00007fe4636445a3 n/a (/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0.8000.0 + 0x925a3)
#3  0x00007fe463643cd9 n/a (/usr/lib/x86_64-linux-gnu/libglib-2.0.so.0.8000.0 + 0x91cd9)
#4  0x00007fe467aa1e39 n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x8ee39)
#5  0x00007fe467b299c4 n/a (/usr/lib/x86_64-linux-gnu/libc.so.6 + 0x1169c4)
ELF object binary architecture: AMD x86-64

What should I do? There was no problem before, but after a computer reboot, this flatpak based program has been unable to be used. I’m not sure if it was caused by a program bug or if I did some destructive operations.
Also, do you need me to provide the dumped core file?

Is this a Fedora Flatpak or from Flathub ?

Can you check for an Update? flatpak update

All common methods are useless, including update, downgrade, repairing, etc.
The software is called web apps. But virtually all software that uses WebKitGTK crashes.

flatpak does not have a downgrade, So I’m not sure there what you tried. Also, is this a Flatpak from Fedora or Flathub ?

No, it does.
Flathub

Sorry but it does not. Again, not sure if you tried something else or have an alias. . .

Here are the flatpak commands :

flatpak 
build                 build-import-bundle   create-usb            enter                 list                  permission-reset      ps                    remote-modify         search                
build-bundle          build-init            document-export       history               make-current          permissions           remote-add            remotes               uninstall             
build-commit-from     build-sign            document-info         info                  mask                  permission-set        remote-delete         repair                update                
build-export          build-update-repo     documents             install               override              permission-show       remote-info           repo                  
build-finish          config                document-unexport     kill                  permission-remove     pin                   remote-ls             run
  • You can try repair, unistall, install, history, ps, run, update

If you are confused with the Terminal, You can do this through the Software Center Remove, the application and reinstall :

I have doubts about the effectiveness of reinstalling the software.
Because my newly installed software is also crashing.

So you used :
flatpak update --commit=<commit_code> <Application ID>

to update the application to a different commit. But :thinking:

Have you removed the application’s config before reinstalling ? Located in

/var/app/xxx.my.application

1 Like

All software that uses WebKitGTK is crashing, not just this web apps flatpak software. In addition, I asked the software developer, and he said that it was WebKitGTK related, not related to his software.
I don’t know if he’s right, so I also want to know if I should provide a dumped core file.

So this is not a Fedora specific issue, but an issue with WebKitGTK ? have you considered filing a bug there?

https://trac.webkit.org/wiki/WebKitGTK#ReportingBugs

Removed f40, intel

I don’t think it’s time yet, because I don’t know if I did something destructive or if it was a software bug.
And I’ve been studying kvm and qemu, there can be destructive operations that I’m not aware of.

Is web apps as an external program really needed, given that Gnome Web (aka epiphany) offers the option of web apps natively?

Hello @fxzxmicah ,
I would re-install webkitgtk6.0 with sudo dnf reinstall webkitgtk6.0 if you’re on workstation.

I tried. It didn’t work.

But I don’t use Gnome Web. In addition, this is not relevant to the matter discussed here.

What was the resulting response from the command? You may have to use --best and --allowerasing options with it to make it work. Another way is to try a distro-sync, sudo dnf distro-sync

It didn’t work means it’s still crashing after the reinstall.

You didn’t answer my question though. What was the result of the command when it was issued? Was the reinstall successful? Did you try sudo dnf distro-sync? What was the result of that command? Also, since this is a flatpak program, did you reinstall that program? It’s likely not at all related to your host system but more than likely about that particular flatpak.

If the result of the command is abnormal, I will naturally say it. If I don’t say it, it means that the commands have been executed successfully.

None of the solutions you mentioned will solve the problem.