Wayland login missing on Fedora 39 workstation

For several days now, when I log in to the system without changing anything on the login screen, leaving just plain GNOME, the session logs in as XORG and not as WAYLAND. I wonder why, since I didn’t change anything? I also don’t have the option to change this cogwheel on the login screen, I can only choose classic gnome, but it doesn’t change anything either. what can I do about it?