Wayland fails after F37 upgrade

Just upgraded my ASUS laptop with Intel onboard graphics to F37. Everything worked except GNOME 43 would not initiate and the system hung. Had to reboot into emergency mode and deactivate Wayland. I could then reboot into GNOME43 in X11 mode. Prior to upgrade GNOME 42 works fine under Wayland.


Mesa Intel HD Graphics 5300 (BDW GT2)

Same problem here, on an Intel NUC. Starting with Wayland activated freezes the user interface (incl. keyboard, so cannot move to different virtual console). But I could ssh into the machine (or boot into run mode 3 by editing the boot command), edit /etc/gdm/custom.conf and disable Wayland. Then I can use the system using X11.

When starting Wayland session from command line (after booting into command line mode), I could also regain access by using ssh to access the frozen (keyboard) machine and killing the gnome shell. So it seems to be some Wayland component hanging.

Did anyone find a solution for this? Or an idea what really hangs? I didn’t have time yet to try tracing the processes to find what really freezes.


Exactly the same problem happened to my laptop asus and intel gpu.
Also you perform the same steps.
This has become a bug that must be reported to those responsible for this topic

I requested a bug ticket: https://bugzilla.redhat.com/show_bug.cgi?id=2143276

Just pulled updates for f37, including for gnome-shell and mutter, and now Wayland is back in business! Issue seems resolved.

– Hendrik

1 Like

Thank you very much, I solved the problem by updating to gnome-shell-43.1-3.fc37.x86_64