Warning: /dev/disk/by-label/Fedora-WS-Live-39-1-5 does not exist Warning: /dev/root does not exist

while installing fedora in my laptop i got this issue

Warning: /dev/disk/by-label/Fedora-WS-Live-39-1-5 does not exist
Warning: /dev/root does not exist

what i have tried so far?

  • reinstall fedora and flash the iso file using fedora media writer, rufus , balenaetcher , live usb creator .

The Fedora 39 Workstation installer doesn’t work on some systems. A workaround is to install an earlier version (e.g., 37 or 38) and then upgrade (upgrades should work across 2 versions, and should be run on fully updated systems, e.g., following the upgrade instructions).

while installing fedora 38 i got this Warning: dracut-initqueue timeout-starting timeout scripts

On my older Gigabyte GA-Z77X-UD5H I had the same error when trying to run the verify option. Running the live image worked and I was able to install from within the live environment.
In the maintenance shell I noticed that the directory /dev/disk/by-label did not exist at all.
Changing the Boot mode from ‘UEFI and Legacy’ to ‘UEFI Only’ is reported on some other forums to work for some but it did not work for me on this hardware.